1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

P38 Air suspension

Discussion in 'Range Rover' started by ranger1942, Aug 12, 2017.

  1. ranger1942

    ranger1942 Member

    Joined:
    Jun 26, 2014
    Posts:
    29
    Likes Received:
    0
    My air suspension refuses to rise from access. Plugged in my Black box and it reads Invalid code.Also says all sensors out of range. Cleared everything but still no go. Tried raising suspension via Black box but no go. Used my emergency valves and suspension raises and stays there. 3rd time in last year this has happened. Anyone got idea whats up with it.
     
  2. Wazzajnr

    Wazzajnr Well-Known Member

    Joined:
    Apr 25, 2016
    Posts:
    859
    Likes Received:
    196
    Location:
    Chorley
    Is the compressor running?
    Look at wammers guide in the technical section. If you have done all the tests there then come back with your findings and there'll be plenty of help.
     
  3. wammers

    wammers STILL BREATHING. Donater

    Joined:
    Oct 19, 2008
    Posts:
    47,873
    Likes Received:
    4,296
    Location:
    Preston Lancs.
    No airy no worky.
     
    myfirstl322 likes this.
  4. ranger1942

    ranger1942 Member

    Joined:
    Jun 26, 2014
    Posts:
    29
    Likes Received:
    0
    Thanks for replying. I left it standing for a couple of hours with the inflation valves attached to prove the air bags were ok, and it didn't move. So i fitted the pipes back in to the valve block, and i was back at square one, vehicle wouldn't rise. I tried to raise the car using the black box, even tried another ECU, still no good. Left it for a while to have a think, went back out and retried using the black box, and lo and behold up it went, and working as normal now. As i said earlier this is the 3rd time now. I know 3 people who have had this happen, one guy said his Landrover dealer told him its a simple job if you have test book. The other 2 were told a new compressor had to be fitted ??. Seems to me there is something in the system that stops communicating on occasions. The last time this happened to me was in January, and i didn't replace any parts then . Really strange this is.
     
  5. Wazzajnr

    Wazzajnr Well-Known Member

    Joined:
    Apr 25, 2016
    Posts:
    859
    Likes Received:
    196
    Location:
    Chorley
    Go through wammers test procedure. Otherwise you will be chasing shadows forever.
     
    kurtjohnson10 likes this.
  6. ranger1942

    ranger1942 Member

    Joined:
    Jun 26, 2014
    Posts:
    29
    Likes Received:
    0
    Yes i will in morning, bit brain dead now from going through the info i have filed. Thanks mate i'll keep u in the loop when i solve it, obviously from the mail i have been getting a lot of P38 owners have had the same problem.
     
  7. PPP38vouge

    PPP38vouge Active Member

    Joined:
    Aug 8, 2013
    Posts:
    373
    Likes Received:
    24
    Location:
    deddington, oxfordshire
    Hi, check white connector blocks behind passenger side footwell kick plate, these get damp and corroded and will cause you problems, also check your scanner connector plug under glove box for corrosion too.
     
    kurtjohnson10 likes this.
  8. ranger1942

    ranger1942 Member

    Joined:
    Jun 26, 2014
    Posts:
    29
    Likes Received:
    0
    Thanks mate i will do that, and all other connections. Going to get some electrical spray this morning.