1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

how to reset ecu???

Discussion in 'Range Rover' started by kj200sx, Oct 5, 2010.

< Previous Thread | Next Thread >
  1. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    hi all can anyone tell me how to reset the ecu on my 4.0 se 1998 p38 as have replaed o2 sensor and maf and been advised to reset the ecu can i do this or does it have to go to garage i have a snap on solus ive recently purchased can it be dne with this ???
     
  2. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    can someone pls let me know how this is done thanks
     
  3. rasheed

    rasheed Well-Known Member

    Joined:
    Feb 17, 2009
    Posts:
    1,805
    Likes Received:
    4
    Location:
    Bangladesh
    its done using Testbook
     
  4. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    31,680
    Likes Received:
    1,312
    Location:
    Near Poitiers SW France
    Or Faultmate
     
  5. eightinavee

    eightinavee Well-Known Member

    Joined:
    Jan 21, 2006
    Posts:
    3,955
    Likes Received:
    51
    Location:
    UK.
    Rasheed is right,but after only swapping one oxy sensor the engine ecu will soon see its output and start trimming the injector pulse width and the long term trims will come back right.Unless it was running for a long time like a complete dog,I wouldnt worry about it.
     
  6. adamrharding

    adamrharding New Member

    Joined:
    Jul 18, 2008
    Posts:
    264
    Likes Received:
    0
    Location:
    Porthcawl way, South Wales in case you didn't know
    I may be applying this idea in a totally incorrect place but I know that disconnecting the BeCM from the battery for 30 minutes depletes its internal battery and is the equivalent of the reset switch on a PC. Is there this kind of option for the engine ECU? You do have to reset the windows and sun roof, but works a treat.
     
  7. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    ive changed both o2 sensor and maf has been running bad since ive owned it and trying to cure the problem after ive changed the 02 sensor came up with 02 sensor high voltage if this has any significance to the problem am out of ideas now just runs badly with low idle and chucks out black smoke if you rev it hard and just stinks of fuel it ticks over normal for a few mins till warm then idles low as if cold start (choke) is not working ?????
     
  8. rewmer

    rewmer Well-Known Member

    Joined:
    Sep 11, 2005
    Posts:
    2,077
    Likes Received:
    18
    Location:
    Clacton, Essex, UK
    Check the fuel pressure.
     
  9. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    how do i do that and what should it be ? may tell me if i data log it or is there a more simple way
     
  10. eightinavee

    eightinavee Well-Known Member

    Joined:
    Jan 21, 2006
    Posts:
    3,955
    Likes Received:
    51
    Location:
    UK.
    It sounds like the oxy sensors are failing to step down to 0v giving a rich signal,where did the sensors come from ?
     
  11. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    i brought them from ebay but were brand new and boxed and the correct part so would not have thought so but i guess its possible what should they change to from as think when i data logged it they were just reading 5 is this 5v? and also had a fault code 02 sensor high voltage ?
     
  12. rewmer

    rewmer Well-Known Member

    Joined:
    Sep 11, 2005
    Posts:
    2,077
    Likes Received:
    18
    Location:
    Clacton, Essex, UK
    Pressure che k is done from the fuel rail. There is a shraeder valve that you screw the gauge on and then start the engine. Rave will give you the pressure. Most good garages will have a gauge. Going from what Eight said, did you you buy a cheap MAF from eBay?
     
  13. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    no was a used genuine maf and the o2 sensor were brand new ?
     
  14. eightinavee

    eightinavee Well-Known Member

    Joined:
    Jan 21, 2006
    Posts:
    3,955
    Likes Received:
    51
    Location:
    UK.
    So are the oxy sensors genuine NTK ones,with the correct plugs etc ? if they are giving out 5v all the time, the engine will run very rich as the ecu is seeing the 5v as a lean reading and will drive the injector pulse width as wide as possible.If the sensors dont switch down to 0v showing a rich signal to the ecu it will just stay rich and stink etc.
     
  15. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    yeah they are i think defo had correct plugs was no need to alter any wiring could there be any other reason for not switching other than a faulty 02 sensor for example maybe the wiring pre plug to the sensor etc as would be suprised if both sensor were faulty to be honest but then this is a rangerover lol
     
  16. eightinavee

    eightinavee Well-Known Member

    Joined:
    Jan 21, 2006
    Posts:
    3,955
    Likes Received:
    51
    Location:
    UK.
    You need to check the heater circuits for them,if the sensors are not being heated they simply wont switch unless the engine is in a high load /speed situation.
     
  17. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    how do i check them is this a case of putting a mm on one of te wires and checking for a voltage or something or am i way of sorry if a stupid question but am tryin to learn and getting abit over my head now lol
     
  18. Kev1000s

    Kev1000s New Member

    Joined:
    Aug 2, 2007
    Posts:
    52
    Likes Received:
    0
    Location:
    Scun_thorpe
    Don,t think your snap on will do it, like stated you need testbook ,faultmate etc.I have both but sadly am in north Lincolnshire..
     
  19. kj200sx

    kj200sx New Member

    Joined:
    Feb 2, 2010
    Posts:
    302
    Likes Received:
    1
    Location:
    northampton
    i have pmd wills who is in northampton who i believe has the bit of kit will you all know how i get on if he gets back to me thanks for the help so far
     
  20. Phil..

    Phil.. New Member

    Joined:
    Oct 7, 2010
    Posts:
    22
    Likes Received:
    1
    Location:
    Olney, Bucks
    I have a T4 system which i am still getting operational and just down the road in Olney so if you dont have any joy and i get it all working, your more than welcome to use it.
     
< Previous Thread | Next Thread >