1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Range Rover 3.6 tdv8

Discussion in 'Range Rover' started by Andyzoe30, Dec 31, 2021.

< Previous Thread | Next Thread >
  1. Andyzoe30

    Andyzoe30 New Member

    Joined:
    Dec 31, 2021
    Posts:
    4
    Likes Received:
    0
    Location:
    Lancashire
    Hi . has anyone done there cam covers on a 3.6 tdv8 ? I replaced the left hand bank cover on mine today as it was cracked and leaking . Everything was fine until I tried to drive it then got these faults on the dash
    Transmission fault limited gears available.
    Hdc fault system not available
    And suspension lowering
    Loads of fault codes when I plugged in to snapon scanner but I think most of them are bogus apart from u2023-86 . Any help would be appreciated
     
  2. biketeacherdave

    biketeacherdave Well-Known Member

    Joined:
    May 22, 2014
    Posts:
    4,173
    Likes Received:
    1,566
    Location:
    south east london
    Charge your battery or get a new 1
     
    tomcat59alan and lynall like this.
  3. Andyzoe30

    Andyzoe30 New Member

    Joined:
    Dec 31, 2021
    Posts:
    4
    Likes Received:
    0
    Location:
    Lancashire
    Hi thanks for the reply. I’ve already put a new battery on thinking that was the problem
     
  4. Saint.V8

    Saint.V8 Dyed-in-the-wool 100% RR Junkie Full Member

    Joined:
    Apr 27, 2008
    Posts:
    16,405
    Likes Received:
    2,235
    Location:
    North Dorset - Near the East & West Stours
    Most likely happened when the battery was replaced. Clear the codes and see what comes back. Not sure on the post 2006 models, but on the earlier L322’s you had to turn lock to lock to reset the steering angle sensor to bring the eas, abs and hdc back on line.
     
  5. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    39,534
    Likes Received:
    6,900
    Location:
    Near Poitiers SW France
    Did you charge the new battery before fitting it?
     
  6. Andyzoe30

    Andyzoe30 New Member

    Joined:
    Dec 31, 2021
    Posts:
    4
    Likes Received:
    0
    Location:
    Lancashire
    We’ll had a few hours on it today and can’t seem to find the fault. Re checked all the engine wiring. Checked the ecu connections battery is new and fully charged . the alternator is charging at 14 volts . I have faults on both map sensor low voltage. Not sure that would cause transmission and hdc faults
     
  7. Rick-the-Pick

    Rick-the-Pick Active Member

    Joined:
    Jun 19, 2007
    Posts:
    780
    Likes Received:
    85
    Location:
    Hove, Sussex.
    Did you wash the engine down afterwards of any oil?
     
  8. Andyzoe30

    Andyzoe30 New Member

    Joined:
    Dec 31, 2021
    Posts:
    4
    Likes Received:
    0
    Location:
    Lancashire
    Hi it turned them both map sensors where faulty and not giving a torque value to the transmission. I replaced both and the car was fine for a week or so . Now I have new problem engine fault on dash and won’t start . I have p026d-01 fuel injector circuit performance bank 1 general electrical failure. I’ve not had much time to look at it at the min , but I no the injector ohms are within spec and I have no voltage at any of the injectors on bank one . Good job I hadn’t sold the old merc ml
     
< Previous Thread | Next Thread >