1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Does anyone know how to get the rear door speakers to work??

Discussion in 'Land Rover Discovery' started by jimbodisco, Dec 29, 2008.

< Previous Thread | Next Thread >
  1. discool

    discool Well-Known Member

    Joined:
    Apr 25, 2007
    Posts:
    12,669
    Likes Received:
    1,447
    Location:
    Sector 12 in Kent, The Garden of England
  2. rojbarker

    rojbarker New Member

    Joined:
    Sep 12, 2007
    Posts:
    544
    Likes Received:
    0
    Location:
    Handover, 'Ampshire
    Cheers for the reply, will have a look at them. :)
     
  3. thebiglad

    thebiglad Well-Known Member

    Joined:
    Jan 18, 2008
    Posts:
    7,382
    Likes Received:
    30
    Location:
    Central France
  4. discool

    discool Well-Known Member

    Joined:
    Apr 25, 2007
    Posts:
    12,669
    Likes Received:
    1,447
    Location:
    Sector 12 in Kent, The Garden of England
  5. thebiglad

    thebiglad Well-Known Member

    Joined:
    Jan 18, 2008
    Posts:
    7,382
    Likes Received:
    30
    Location:
    Central France

    Hi Peter, still "access denied" - never had this before so I don't know what's going on??

    Dave
     
  6. discool

    discool Well-Known Member

    Joined:
    Apr 25, 2007
    Posts:
    12,669
    Likes Received:
    1,447
    Location:
    Sector 12 in Kent, The Garden of England
  7. thebiglad

    thebiglad Well-Known Member

    Joined:
    Jan 18, 2008
    Posts:
    7,382
    Likes Received:
    30
    Location:
    Central France

    Hi Pete thanks for this, but unfortunately I'm getting the same reply ???


    Never experienced this before??
     
  8. discool

    discool Well-Known Member

    Joined:
    Apr 25, 2007
    Posts:
    12,669
    Likes Received:
    1,447
    Location:
    Sector 12 in Kent, The Garden of England
    Hi Dave, I get "access denied" on some sites so I move on and so haven't looked into why. Maybe the security level is set to high on the pc something as simple as that. It's a shame as it's an informitive site on all things in ICE plus there's other electonic products too.

    I off to google "access denied"

    Regards
     
  9. chris_debian

    chris_debian New Member

    Joined:
    Jul 2, 2006
    Posts:
    51
    Likes Received:
    0
  10. vivnap

    vivnap Banned

    Joined:
    Nov 10, 2008
    Posts:
    2,610
    Likes Received:
    4
    Location:
    south normanton
    YESSSSSSSSSSSSSSSS YES YES YESSSSSSSSSSSSSSSSSS ive dont it !!!!!!!!!!!!!!!!!!! i bought one of them wires off ebay to get the rear door amp/speakers working fitted it and ??????????????? nothing....... i was bloody fuming so i got out the sterio instructions but nothing i did would get the speakers to make any noise. in frustaration and anger i shoved the sterio in the hole quite hard and my finger caught a button and ??????????????????? YESSSSSSSSSSS YES THE DOOR SPEAKERS WORK. in fcukin exstatic to say the least !!! hehehehe what a stroke of luck my finger caught the AF/TA in RDS what ever that does but who cares it works
    :clap2::bounce::banana::D:D:D
     
  11. gotoneatlast

    gotoneatlast New Member

    Joined:
    Aug 3, 2008
    Posts:
    3,431
    Likes Received:
    0
    Location:
    berkshire,uk
    at last!

    nice one viv, you're a credit to the blag it and perserve contingent.
     
  12. vivnap

    vivnap Banned

    Joined:
    Nov 10, 2008
    Posts:
    2,610
    Likes Received:
    4
    Location:
    south normanton
    cheers hehehehe im buzzing i got them to work even if it was a fluke cos i threw me dummy out and got mad with the sterio. but im not one to give in and it worked out ok :)
    the difference in sound quality is AMAZING ! im supprised how much difference the rear door speakers make to the sound system. now to get some banging tunes on em !:D
     
  13. gotoneatlast

    gotoneatlast New Member

    Joined:
    Aug 3, 2008
    Posts:
    3,431
    Likes Received:
    0
    Location:
    berkshire,uk
    don't they just,
    now your gonna start tearing around in time to the music!,
    low gears to high for the bridge into gtr solo:D
     
  14. vivnap

    vivnap Banned

    Joined:
    Nov 10, 2008
    Posts:
    2,610
    Likes Received:
    4
    Location:
    south normanton
    :banana:you know it !!!
     
  15. finallysnapped

    finallysnapped Well-Known Member

    Joined:
    Jun 22, 2010
    Posts:
    1,127
    Likes Received:
    19
    Location:
    East Lothian
    Today I spliced two RCA connectors onto the red and black wires (cut off the weird original plug). I still have nothing coming out of the rear speakers or the ones on the boot door.

    My stereo doesn't have anything labelled pre-amp out so I plugged into cables labelled "front left" and "front right" assuming this would be right but maybe not.

    The other thing I noticed yesterday as I had the door card off the boot doing the door spring fix (pain in the hole) was that there is a wire that has been snipped inside the door. Well two wires which I assume were joined at some point. The other lead in there is for the heated rear window so I was wondering if this cut cable was the power to the amp or if it didn't have that?

    edit:

    This is the wiring diagram for my stereo

    [​IMG]
     
    Last edited: Dec 22, 2011
  16. discool

    discool Well-Known Member

    Joined:
    Apr 25, 2007
    Posts:
    12,669
    Likes Received:
    1,447
    Location:
    Sector 12 in Kent, The Garden of England
    Your right u don't have a pre-amplified output but you can get an interface that will connector to a loudspeaker output u only need one as bass is mono, that will allow you to adjust the gain, connecting the output direct to the sub amp could blow the amp.

    With the cut wire just identify it and if it goes to the amp reconnect it.
     
  17. keithrturner

    keithrturner New Member

    Joined:
    Dec 31, 2011
    Posts:
    8
    Likes Received:
    0
    Location:
    Kidderminster
    Thanks to this thread I managed to get my rear subs working again after changing the head unit - I got an RCA lead, cut the wires and connected both the sleeves into 1 crimped connector and the cores into another. These I simply plugged into the original connector to avoid cutting any LR wires, plugged into the RCA outs on the head unit and Hey Presto - music levels restored!
     
  18. john snoo

    john snoo Active Member

    Joined:
    Sep 2, 2016
    Posts:
    430
    Likes Received:
    69
    Location:
    uk
    Golden oldie I know, but i read this thread when researching whether my sub speakers are knackered or not. I am still not sure. They have a very weak and muffled sound but there is sound coming out of them, barely. I thought I should just replace them anyway so I had a butchers on fleabay and got the shock of my life! https://www.ebay.co.uk/itm/LAND-ROV...933225?hash=item28917320e9:g:K9gAAOSwPyRehjpJ

    OOOOOOOOOWWWWWWWWWW MUUUUUCCCCCCCCHHHHHHHHHH?????!

    Back to drawing board. Grateful for any tips on replacing these:

    [​IMG]
    [​IMG]

    PS I read on this thread that some people have an amp behind the subs. I haven't ripped it off yet to see if I have, but if i do have one, does the amp only drive the sub? I have never been sure what audio system my D2 has. The seller said definitely not Harmon Kardon, and no logos visible anywhere. but I do have a multi changer under driver seat and a small metal box under front passenger seat which may be an amp. Plus the subs on back door of course. The head unit is original Apline LR spec. I am not too impressed with the sound on it. The clarity is nice, but the bass is pretty pathetic/non-existent. I may consider upgrading more than just the speakers. But for now just finding replacement speakers would be a good start, if anyone can point me in right direction?
     
  19. thebiglad

    thebiglad Well-Known Member

    Joined:
    Jan 18, 2008
    Posts:
    7,382
    Likes Received:
    30
    Location:
    Central France
    Hello John, the two loudspeakers on the back door are driven by an amplifier also on the same panel. So, the likelihood is that to diagnose this problem you will need to remove the panel from the back door, then disconnect the wires attached to the speakers and temporarily attach them to a separate pair of speakers.

    Now evaluate what this second pair produce - if the volume is satisfactory the faulty parts are the LR speaker units, if the volume remains little or nothing then it's most likely the faulty part in the sub amplifier.

    I had a similar problem and replaced the speakers with better quality units purchased quite cheaply from Ebay. The sound quality was significantly improved.

    Good luck
     
  20. john snoo

    john snoo Active Member

    Joined:
    Sep 2, 2016
    Posts:
    430
    Likes Received:
    69
    Location:
    uk
    Thanks very much. Yes that's a sensible approach. Just not sure if I must buy dedicated subwoofer speakers, or any normal 3 way speakers?
    How did you replace them, did you just match power/ohms/screw fitment etc?
    If you can remember the ones you bought please let me know, if you were impressed I would gladly just go for those! Thanks again, would be nice to get these working
     
< Previous Thread | Next Thread >