1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Disco 4 problem. Stereo climate and internal indicators not working

Discussion in 'Australia' started by Dsldog, Mar 1, 2019.

< Previous Thread | Next Thread >
  1. Dsldog

    Dsldog New Member

    Joined:
    Feb 28, 2019
    Posts:
    2
    Likes Received:
    0
    Location:
    Victoria
    Hi all. Need help badly.

    2011 disco 4 3.0

    Issue started car not recognising the key. This was fixed but now when the car get to running temp climate stereo and indicators cut out, but only inside.
    Have replaced the main ecu reset the original ecu checked wiring for chassis rub mechanics have tried everything they can think of.
    Turn the car off. Starts it next day it’s fine until working temp. Weather driving the car or letting it warm in the factory.
    Landrover said put heater on dash get it hot that did nothing. Can’t find any breaks in wire looms.
    Possible separate ecu?
    Fuse/ relay ?
    Heat sensor in car behind dash ?
     
  2. goonarmy

    goonarmy Annoyed by new forum LZIR Despatch Agent

    Joined:
    Oct 14, 2007
    Posts:
    34,503
    Likes Received:
    11,192
    Location:
    Hornchurch
    Tried the disco section?
     
< Previous Thread | Next Thread >