1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

P38A Air, wheres it going??

Discussion in 'Range Rover' started by Dopey, Oct 7, 2017.

< Previous Thread | Next Thread >
  1. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    Sorry yet again, not getting air into the front suspention, the 2 wheels are not going up, the back is fine, nor this could be???? solenoid?? diaphragm?? both?
    anyone know what ones to check for the front please??
     
  2. Saint.V8

    Saint.V8 Dyed-in-the-wool 100% RR Junkie Full Member

    Joined:
    Apr 27, 2008
    Posts:
    16,347
    Likes Received:
    2,157
    Location:
    North Dorset - Near the East & West Stours
  3. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    Tnx saint
     
  4. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    Looking at it, I dont get why its stopping air from going in the front ones though??
     
  5. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
    Weak compressor? Fills rear bags first
     
    Grrrrrr likes this.
  6. pwood999

    pwood999 Well-Known Member Full Member

    Joined:
    Nov 6, 2006
    Posts:
    1,582
    Likes Received:
    700
    Location:
    Near Heathrow.
    If the system is low on air, then once the rear bags inflate, the compressor should kick in. If the pump is feeding a leak, it probably will not get enough pressure in the tank ti inflate all four corners.

    Get the tank full first. Let it fill the rear as this is working. Next open drivers door to disable auto-leveling. Then try raising the front manually with EAS-Unlock or Nanocom. Open the two front corner valves first, and then open the Inlet valve.
     
  7. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    Ok did what you said, let the back go up first open the door, the front did go up very slow, the wifes gone out to drive it around, I cant find my EAS unlock software right now, I will have a hunt for it, and try to set it up
     
  8. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    The switch (on the dash) will give a solid (mid ride height ((false reading)) when I press it, it when sets itself (flashing as it should) and filling with air
     
  9. Big vee

    Big vee Active Member

    Joined:
    Aug 26, 2008
    Posts:
    247
    Likes Received:
    2
    Location:
    Near Kingston upon Thames Surrey
    I had this I rebuilt the valve block and it sorted it . look in the for sale some one selling recon valve block and brand new compressor
     
  10. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    I put a new pump in , rebuilt 2 blocks
    took these conflicting pics, from diagnostics.... reset faults, still doing what and when it wants, Im about to give up and ****ing junk it, seriously I only have so much patients with it all SAM_1477.JPG SAM_1476.JPG SAM_1475.JPG
     
  11. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
    Spurious faults, don't think you have a proper connection to ECU
     
    Grrrrrr and Dopey like this.
  12. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    What my leads to the laptop you mean?
     
  13. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    You clear faults with pressing the UNLOCK EAS right?
     
  14. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
    I would unplug from OBD port then plug in again, think you should be getting the FF readings in both columns to confirm good connection
     
  15. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    Seriously never mind had enough of it, thanks for the help though, sticking it on ebay
     
  16. kurtjohnson10

    kurtjohnson10 Well-Known Member

    Joined:
    Dec 31, 2012
    Posts:
    16,467
    Likes Received:
    19,650
    Location:
    midlands
    dont give up yet mate, it may be just a bad connection as stated on your lead , have you tried plugging the lead into another port on your pc?
     
  17. wammers

    wammers No longer with us, RIP Donater

    Joined:
    Oct 19, 2008
    Posts:
    58,171
    Likes Received:
    11,651
    Location:
    Preston Lancs.
    EASunlock is not connected to the ECU. You need green good idle before you can do anything.
     
  18. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
    I got good idle, and now its telling me the EAS is locked working and its 15mph, didnt show no faults
     
  19. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
    Follow Wammers EAS guide in the technical section. Air leak in front bags?
     
  20. Dopey

    Dopey Well-Known Member

    Joined:
    Sep 7, 2006
    Posts:
    5,871
    Likes Received:
    2,350
    Location:
    Heathrow
< Previous Thread | Next Thread >