1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Series 3 Won't start up!

Discussion in 'Series Land Rovers' started by Jake P, Jan 14, 2020.

< Previous Thread | Next Thread >
  1. Jake P

    Jake P Member

    Joined:
    Jan 1, 2020
    Posts:
    25
    Likes Received:
    6
    Location:
    Malta
    No worries lads, giving the plugs a good clean would definitely help. I'll check whats wrong with the alternator next. If its something major, will definitely opt for a better one!

    Thanks for your knowledge and time!
     
    steve2286w likes this.
  2. Bobsticle

    Bobsticle De Villes Advocaat

    Joined:
    Aug 8, 2013
    Posts:
    18,317
    Likes Received:
    20,893
    Location:
    Manchester
    The alternator on mine was goosed when I got it. It was only giving out about 12.5 volts. I had the usual twiddle with its wires and plugs and checked the belt tension with no results. Changed it for an eBay replacement Lucas ‘type’ one and had no issues for the last 4 years. I’m not positive but I think it was about £50 but a high ampage one. They are probably dearer now :rolleyes:
     
< Previous Thread | Next Thread >