1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

p38 diesel issues

Discussion in 'Range Rover' started by hendoaaron, Nov 24, 2010.

  1. hendoaaron

    hendoaaron New Member

    Joined:
    Jan 19, 2010
    Posts:
    41
    Likes Received:
    0
    alright lads!

    many thanks for your help, managed to sort most of my issues out i posted a few weeks ago.
    however i have a few more, i have a issue when my rover is cold, it will start but takes about three goes and a big plume of black smoke comes out ofmy exhuast, new glow plugs getting 11.4 ish at each glowplug. when its hot starts no worries! any ideas? other one is my rover always runs cold never gets remotely close to half way even when towing, my heater works a treat hot air within minutes of starting so to me that rules out open stat i think. any ideas? cause i think if i can get it running right it might improve my fuel consumpsion! is this correct plus when i went to change my glow plugs they where covered in soot running to rich cause its cold?
    also can you replace bulbs on a hevac unit cause my temp control each side, fan control and heated windows front and rear lights are out. they work fine just no lights when dark.
    oh and do you oil coming out of your turbo is this normal just got **** of oil in inlet manifold caked in it to be honest and gunk at exhuiast pipe on turbo as well.
     
  2. Mike v.t.s

    Mike v.t.s New Member

    Joined:
    Aug 25, 2010
    Posts:
    459
    Likes Received:
    0
    Location:
    Chorley, lancashire
     
  3. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    28,673
    Likes Received:
    102
    Location:
    Near Poitiers SW France
    11.4 volts at the glowplugs is a bit on the low side. Check earths and battery connections and the condition of the battery, put your voltmeter across the battery terminals and operate the glow plugs, if the battery drops to 11.4 change it or try charging it. Then if needed check the glowplug relay and the ignition relay in the engine compartment fuse box, while you are at it have a good sniff of the fuse box for smells of burning plastic.
    It could of course be fuel run back, so check for air in the clear plastic pipe from fuel filter to FIP and check the leak off pipes.
    As for the low running temperature, I would suspect that the stat is not fully closing.
    Cold running will definately adversely affect your fuel consumption.
     
  4. wammers

    wammers Purveyor of tech stuff. REPAIR EVENTS ORGANISER. Donater

    Joined:
    Oct 19, 2008
    Posts:
    40,961
    Likes Received:
    1,652
    Location:
    Preston Lancs.
    Dear Pete the plumber,
    I am having problems with my central heating system, it was not getting warm so i changed the thermostat. Now it never switches off, is on all the time and is costing me a bomb in gas bills. Because the old thermostat got in the way i took it off the wall in the kitchen and ran a extension wire and fixed it to the wall outside. Any advice would be gratefully recieved.:D:D:D
     
    Last edited: Nov 25, 2010
  5. Bromsgrove Defender

    Bromsgrove Defender Well-Known Member

    Joined:
    Nov 21, 2007
    Posts:
    5,756
    Likes Received:
    10
    Location:
    Out to lunch


    Yer not usin heating oil fer fuel are ya? :eek: :eek:
     
    Last edited: Nov 25, 2010
  6. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    28,673
    Likes Received:
    102
    Location:
    Near Poitiers SW France
    French heating oil is red diesel, works fine:D
     
  7. wammers

    wammers Purveyor of tech stuff. REPAIR EVENTS ORGANISER. Donater

    Joined:
    Oct 19, 2008
    Posts:
    40,961
    Likes Received:
    1,652
    Location:
    Preston Lancs.
    I cannot believe this guy has jury rigged a ECU temp sensor to where it is cooler. Hence the Pete the plumber remark. It is beyond belief anyone would do that.
     
  8. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    28,673
    Likes Received:
    102
    Location:
    Near Poitiers SW France
    And then he wonders why he has crap fuel consumption:rolleyes:
     
  9. hendoaaron

    hendoaaron New Member

    Joined:
    Jan 19, 2010
    Posts:
    41
    Likes Received:
    0
    hi there this is for wammers!

    thanks for your comment! not needed fella!

    i am very aware how a stat works!

    there two sensors for the coolant temp on a p38 diesel the front one feeds gauge for temp reading obviously also feeds ecu for fuel consumption to pump etc, and the rear one gives ecu a signal to turn on glow plugs depending on coolant temp.
    for some reason not known to me but we do own p38 there are sent to try us! the p38 software when the coolant is hot can tell the ecu not turn on glow plugs hence no start or takes a while. i recieved this info from a colleague who knows these things well, my fuel consumption hasnt changed since ive done it and i get engine coolant temp fine on my gauge.
    the reason my p38 was running cold was vicous fan permantly on so it sorted now.

    but yes thanks for your smart comments!

    to the other lads on here many thanks for all your help
     
  10. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    28,673
    Likes Received:
    102
    Location:
    Near Poitiers SW France
    One sensor if for the Guage, the other for the engine ECU, so that doesn't alter the fact that if the sensor for the ECU is constantly telling the ECU it's cold, it will be over fueling. Was it not you on another thread complaining about your fuel consumption?
     
  11. wammers

    wammers Purveyor of tech stuff. REPAIR EVENTS ORGANISER. Donater

    Joined:
    Oct 19, 2008
    Posts:
    40,961
    Likes Received:
    1,652
    Location:
    Preston Lancs.
    One sensor feeds the gauge on the dash only, the other one, the one you have stupidly disconnected and jury rigged feeds the ECU to inform it of engine temp changes and so fueling adjustment and glow plug operation. Best thing if you don't understand something, which you obviously don't. Bettter not to mess with it. Rather like putting your central heating thermostat outside don't you think. If you do stupid things expect to have your leg pulled. Have a nice day.
     
    Last edited: Nov 27, 2010
  12. hendoaaron

    hendoaaron New Member

    Joined:
    Jan 19, 2010
    Posts:
    41
    Likes Received:
    0
    yeah it was

    the vicous fan was on permantly so it was thats why running cold runs like a dream now. i have been told by a range rover mechanic that that sensor doesnt effect the fuel consumption. plus it didnt make any difference to my fuel economy afdter i did it
     
  13. the hooded claw

    the hooded claw New Member

    Joined:
    Jun 18, 2006
    Posts:
    1,743
    Likes Received:
    1
    Location:
    Fleetwood Lancs, Besides the Sea!!!
    Firstly "Viscous Fans" ALWAYS run "Perminantly" (As they are turned by the god damned engine) Do you by any chance mean the front electric cooling fans ???? ....

    Explain please ....................

    DEAD WRONG there Matey!!!!
     
    Last edited: Nov 27, 2010
  14. wammers

    wammers Purveyor of tech stuff. REPAIR EVENTS ORGANISER. Donater

    Joined:
    Oct 19, 2008
    Posts:
    40,961
    Likes Received:
    1,652
    Location:
    Preston Lancs.
    Your mechanic is wrong, god help his customers. The ECU engine temp sensor, along with inlet air temp sensor and fuel temp sensor pass information to the ECU. The ECU then computes that information and instructs the fuel pump to deliver differing amounts of fuel for a given engine, inlet air, fuel temp. The throttle position sensor, and engine speed sensor along with the number four injector control injection and injection timing over the rev range, via the ECU. The MAP sensor adjusts fueling via the ECU for differing manifold pressures. If the ECU temp sender is constantly cold the engine will run at cold start settings all the time. If the ECU temp sensor fails and the ECU thinks the engine is hot all the time you will have trouble cold starting. But from your other posts it would seem you have a problem with the glow plugs. The glow plugs should not work when engine is hot unless you have the hot start fix fitted. When the engine is cold you should be able hold the viscous fan with finger pressure whilst the engine is started. But not be able to when the engine is hot. A rolled newspaper maybe better than your fingers if you don't know what your doing.
     
    Last edited: Nov 28, 2010
  15. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    28,673
    Likes Received:
    102
    Location:
    Near Poitiers SW France
    So, just how many (or how few) miles to the gallon do you get? You have to remember the LR skimped every penny they could on production, no way would they fit a sensor that was not needed.
     
  16. gtland

    gtland New Member

    Joined:
    Jun 6, 2009
    Posts:
    742
    Likes Received:
    0
    Location:
    Normandy
    I`ve nothing to add to the comments about the temp sensors. Wammers & Datatek have covered that well, and Hoodie is being his normal laid-back self with his comments on the fans, (they are vicious if you try `n` stop one with your fingers tho`).
    I would like to add a comment about the OP query about turbos tho`. As Mike says SOME oil is blown from the turbo into the intercooler, but excessive oil in the inlet can be a warning of problems.
    If the engine is using oil with no visible drips then investigate further.
    With warm engine let it tickover for 10 mins, then boot it, blue smoke? Investigate.
    With cold engine take pipe off turbo insert finger.(Warm hands so as not to make her squeal) If you can fell any play on the turbo shaft/vanes or any roughness is evedent on edges (small mirror helpful here); investigate further.
    If you`ve all the above symptoms you have a shot turbo.
    Turbos can fail in different ways, but if you`re unlucky they can take out the whole engine with them. (bits of turbo sucked thro intercooler into pots, and/or a runaway situation as the engine runs out of control on lube oil). That`s a worst case scenario but be warned.
    That`s me off my hobby-horse again.

    PS Always use good quality oil ETC ETC and you don`t say what milage the engine is on?
     
    Last edited: Nov 28, 2010
  17. wammers

    wammers Purveyor of tech stuff. REPAIR EVENTS ORGANISER. Donater

    Joined:
    Oct 19, 2008
    Posts:
    40,961
    Likes Received:
    1,652
    Location:
    Preston Lancs.
    Yeah just to add to the fan stopping thing. I did say they can be held when cold by finger pressure whilst the engine is started. I would not recommend sticking your fingers in there with the engine running, in particular if you've never done it before, were getting the rotation wrong can be a little painful. That's why i mentioned the rolled newspaper. Less blood that way.:D:D:D
     
  18. gtland

    gtland New Member

    Joined:
    Jun 6, 2009
    Posts:
    742
    Likes Received:
    0
    Location:
    Normandy
    Practical experience is often the best teacher, but think we agree this is an exception!