1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Disco 2 M & Lights flashing when engine is cold

Discussion in 'Land Rover Discovery' started by Bryan Organ, Feb 20, 2018.

< Previous Thread | Next Thread >
  1. biketeacherdave

    biketeacherdave Well-Known Member

    Joined:
    May 22, 2014
    Posts:
    2,750
    Likes Received:
    467
    Location:
    south east london
    If you have not yet changed the battery then change it nothing to lose everything to gain, I bought our d2 with m and s lights both on everything pointed to gearbox it turned out to be a 10 year old air filter had collapsed blocking the air intake I also put the car on a battery charger for 24 hours cleared the fault codes and its been fine since regarding this issue.

    I did suffer complete battery failure on Monday after a very cold night, cold kills batteries, we have used the heated screen a fair few times and we have the heated seats on constantly. It was slow to crank almost didn't crank at all new battery fitted and away it went. Buy a deep cycle heavy duty off the bay........good luck
     
  2. ROY SIMPSON

    ROY SIMPSON Active Member

    Joined:
    Dec 13, 2011
    Posts:
    100
    Likes Received:
    4
    Location:
    Middlewich cheshire
    Just to clarify your fault
    1) on first starting your car when cold, you can start it in p or n and the m&s lights only start flashing once you select d and drive away when you experience a jolt and the car goes into limp mode.
    2) if you turn the car off before the engine has achieved normal operating temperature when you try to restart the car do the same sequence of events happen or do the m&s lights start to flash as soon as you start up before selecting d or after selecting d.
    3) when the car is at normal operating temperature you can turn the car off then on again and it operates normally.
    If the m&s lights do not come on when you first start up what happens when you manually select first gear and drive away then select 2 nd gear and then 3rd gear and finally d.
     
  3. eightinavee

    eightinavee Well-Known Member

    Joined:
    Jan 21, 2006
    Posts:
    3,940
    Likes Received:
    48
    Location:
    UK.
    Yes, please list clearly ALL the logged codes. That it behaves once the engine is hot indicates to me that its very likely low battery voltage causing it. Forget that you have been told the battery is OK, what needs to be done is to monitor the battery voltage with a scope whilst starting from cold. If the fault codes in the gearbox ECU include CAN timeout, or CAN missing messages, this is a sure sign of the voltage being dragged down enough during cranking to halt the boot up procedure in the gearbox ecu.
    Taking the WXYZ switch apart and cleaning it is not enough,there are a pair of contacts in there that arc every time you move the shifter through the reverse gear position.(Try starting the car in neutral and then going straight to D,this will prove if its the WXYZ switch) The contact on the moving arm and the contact in the body of the switch need polishing back to a clean surface to make them work properly.The moving contact may also need bending VERY carefully to make it sit straight and contact correctly. You then need to operate the reversing lights through a relay to stop it happening again - takes the 42w load off the poor WXYZ switch...
     
  4. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    Okay here goes to answer your points:-
    1. We always start the car in P, the M & S lights flash after driving in D (which must be 1st gear) and after the jolt. The D flashes and the car is in limp mode ie. 3rd gear.
    2. The answer is yes, as we have two choices one to sit with the engine running until its hot or two, switch off, set alarm, wait, switch the alarm off and restart the car.
    3. At normal temperature yes we can turn the engine off and on again and all is well.

    We did try once selecting 1st, then 2nd and then 3rd but the jolt occurred and the M & S lights came on.
     
  5. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    It seems we need to get the battery checked, but by someone who understands your comments ie scope etc. As a start, we are going to get the battery tested at an independent garage. Once we get that done I will report back.
    Thanks in advance.
     
  6. ROY SIMPSON

    ROY SIMPSON Active Member

    Joined:
    Dec 13, 2011
    Posts:
    100
    Likes Received:
    4
    Location:
    Middlewich cheshire
    From your answers I do not think your battery is causing the fault.
    When the ignition is turned to position 2 the electronic automatic transmission ecu ( eat ecu) receives this information and simultaneously reads the voltage signal received from the xyz switch nominally 12 volts.

    The eat ecu constantly monitors the signal received from the xyz switch and if the signal ceases for more than a fraction of a second ( when changing gear manually), through a short or open circuit, misaligned or faulty m&s switch or voltage drop caused by poor battery when cranking engine it triggers limp mode and flashing m&s lights immediately.
    If it were a faulty battery I would expect the fault to be present soon after starting the car certainly before you drove off and you would be starting in 3rd gear (default settings for limp mode).
    The problem with intermittent xyz switch circuit faults is that the fault does not clear itself when the cause ceases only when you close the system down so you don't know how long the fault is present.
    If you have access to nanocom, hawkeye or test book diagnostic tools you can read live data from the xyz switch in both the bcu and eat ecus.
    When the fault is active note the signals to the wxyz feeds when selecting prnd321 at both bcu and eat ecus and compare them with each other and the table found in rave in the automatic transmission section. This may indicate if you have an electrical circuit fault.
    Be aware if you use nanocom you may need to reverse the column headings from wxyz to read zyxw in either the bcu or eat table, it will be apparent when you compare them with rave table. This is not fool proof but could help.
    If you don't have a copy of rave the official land rover discovery work shop manual you can download it free on the d2boysclub forum and read up on automatic transmission to better understand your problem.
    I would also experiment by driving some distance in 1st gear manually to see if you can create the fault in 1st gear, then 2nd , 3rd and finally d changing manually each time to see if you can pinpoint exactly when the fault occurs as it could be a physical fault in the gear box or the transmission fluid that that changes when it warms up.
     
  7. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    Thank you Roy for all the comments, I have registered on d2boysclub and await them activate my account. You obviously have a vast knowledge on this subject, whereas I have none. Our car is our life line in pulling our caravan away as much as we can afford. Knowing who to go to without incurring huge labour bills is a problem, however once I have had a look at a copy of rave may be I will be able to sort something out. Thanks agin, I will keep you posted.
     
  8. janderson41

    janderson41 Active Member

    Joined:
    Mar 13, 2010
    Posts:
    375
    Likes Received:
    8
    Location:
    Howwood Renfrewshire
    Further to my previous post. Dreaded m&s lights have not appeared again.
    Had the car checked over by a Hawkeye Tool and only faults referred to the difflock, which i don,t have.
    Haven't been out since Monday because of the snow, hopefully tomorrow, and see what happens.
     
  9. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    We are in the same situation, the weather is preventing sorting the problem out. I have downloaded RAVE (the manual) but as yet I cannot make sense of the files, its all about "mounting" them!!!!
     
  10. iansoady

    iansoady Active Member

    Joined:
    Oct 11, 2006
    Posts:
    534
    Likes Received:
    30
    I expect you've downloaded an ISO file which is a CD image. You can burn this to a blank CD or (if you have Windows 10) open it directly or (pre-Windows 10) you can get free software to do this.

    I've copied the whole thing to my hard drive so I don't have to faff around with CDs.
     
  11. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    You're correct I did download ISO file and I have burnt it to a disk, but none of the pdf files can be read, the videos run but frankly, they are not very good quality. I was advised to get this manual so that I could read up on automatic transmission to better understand my problem, but as yet I have found nothing of use.
     
  12. iansoady

    iansoady Active Member

    Joined:
    Oct 11, 2006
    Posts:
    534
    Likes Received:
    30
    Try copying it all to your hard drive under a suitable folder but with the same structure as on the CD.
    You do need to start it up using RAVE.exe as it uses an old version of Adobe Acrobat.

    TBH RAVE is infinitely better than Haynes or anything else.
     
  13. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    Okay, so I copied the disk to a folder on the laptop, but cannot open all of the files. You suggest opening using RAVE.exe but how? sorry but my knowledge is more limited than I thought.
     
  14. brian47

    brian47 Well-Known Member

    Joined:
    Jan 24, 2013
    Posts:
    7,916
    Likes Received:
    4,406
    Location:
    Bridgend, Mid Glam. Somebody's got to live here.
    @Bryan Organ
    You've copied the disk to a folder on your computer, so if you open that folder (double click usually) you should have a list of contents shown in the picture below.
    You will then see two green oval icons, to start RAVE, double click on the "Application" icon. After the first run of RAVE, the program will automatically place a "start" icon on your desktop for easier future use.
    If you don't have the list of files in the picture then you probably haven't written the program to the CD correctly. It's not a straight "write as data" burn, but you should burn the CD as "Burn an image" which unpacks the downloaded .iso file into its constituent files as it's being burnt to the CD.

    Untitled.gif
    My computer is set so that the files don't show the filetype (.pdf, .exe, etc.)
    I've added the file "Disco 2 part catalogue url" myself, so you won't have that one.
     
    Last edited: Mar 4, 2018
  15. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
     
  16. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    I don't have the two green oval icons, yet I believe I burnt the RAVE.iso as Burn an image. (see picture)[​IMG] and the picture [​IMG] shows the list of files.
    Not sure if the two images are there, as I have never attached screen prints here before. In the meantime, I will have another go. Thanks for your help.
     
  17. brian47

    brian47 Well-Known Member

    Joined:
    Jan 24, 2013
    Posts:
    7,916
    Likes Received:
    4,406
    Location:
    Bridgend, Mid Glam. Somebody's got to live here.
    Your two images don't show. To place an image, you should use the button "Upload a file" and navigate to the image you wish to post.
     
  18. sierrafery

    sierrafery Well-Known Member

    Joined:
    Jun 30, 2007
    Posts:
    10,181
    Likes Received:
    869
    Location:
    West of Transylvania
    There is some conflict in Win 10 which doesnt let RAVE to open even though Acrobat works on other PDFs, my son is good with computers and tried everything without success, it worked on untill a point then after some system updates it stopped working
     
    Last edited: Mar 4, 2018
  19. sierrafery

    sierrafery Well-Known Member

    Joined:
    Jun 30, 2007
    Posts:
    10,181
    Likes Received:
    869
    Location:
    West of Transylvania
  20. Bryan Organ

    Bryan Organ Member

    Joined:
    Feb 4, 2018
    Posts:
    25
    Likes Received:
    1
    Location:
    Wombourne
    I have downloaded the rave again, but its obviously not the correct download. So where did you get yours from?
     
< Previous Thread | Next Thread >