1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

freelander trouble

Discussion in 'Land Rover Freelander' started by nicholas2074, Jan 12, 2012.

< Previous Thread | Next Thread >
  1. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    hi everyone
    can any one help me
    my 1998 freelander stop running on saturday morning so i checked and cleaned the following
    spark plugs
    injectors
    fuel pump
    my local lr dealer said it could be hg but it had a new one about a year ago then he said it might be because i have a hole in the flexy pipe on the exhaust just looking for any ideas ??????????????
    thanx
     
  2. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    1.8? 2.5?
    oil in coolant?
     
  3. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    hi mate its a 1.8 and there is no oil in the coolant
     
  4. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    Is there a spark at the plugs?
     
  5. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    yeah the spark is good
     
  6. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    Fuel getting through?
     
  7. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    If fuel not getting through try the fuel cut_off switch under the bonnet
     
  8. bigshoza

    bigshoza New Member

    Joined:
    Jul 11, 2011
    Posts:
    32
    Likes Received:
    0
    My flexi snapped completely in half and still ran so it ain't that?
    Is it trying to start or just ticking?
    Check compression and spark on all 4
     
  9. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    hi there peps
    there is fuel getting up and a good spark
     
  10. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    Its turning but not firing!

    Could be Immobiliser fault but it wunt let you see a spark would it.



    An after thought if there's a hole in the exhaust it may affect the lambda sensor so the ecu won't let the engine run
     
    Last edited: Jan 12, 2012
  11. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    thats what the lr dealer said it does start just wont idle and stalls straight away
     
  12. Bigwheel

    Bigwheel New Member

    Joined:
    Jan 9, 2012
    Posts:
    39
    Likes Received:
    4
    Is it making any attempt to start?
     
  13. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    yeah and it will run if i rev it but it stalls when idleing
     
  14. Bigwheel

    Bigwheel New Member

    Joined:
    Jan 9, 2012
    Posts:
    39
    Likes Received:
    4
    disconnect the battery for 10 mins then reconnect and try to start
     
  15. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    thanks bigwheel will try in the morning and let you know
     
  16. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    When you re-connect the battery it will wind down the back window and you will have to re-calibrate your remote by pressing the lock button 5 times.
     
  17. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    thanks mate is there anything esle i can try????
     
  18. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    Check all earths, battery connections and fuses.

    Get the exhaust fixed anyway.

    Good luck :)
     
  19. nicholas2074

    nicholas2074 New Member

    Joined:
    Jan 12, 2012
    Posts:
    12
    Likes Received:
    0
    do i have to press it fast or slow i know it sounds stupid but i wanna get it right
     
  20. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    187
    Location:
    Yorkshire
    Only had to do it once meself...i think you just press...pause....press etc.........
     
< Previous Thread | Next Thread >