1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

V8 idling issue

Discussion in 'It's A V8 Mate!!' started by Aydena, Mar 10, 2009.

< Previous Thread | Next Thread >
  1. Aydena

    Aydena Active Member

    Joined:
    Feb 27, 2009
    Posts:
    122
    Likes Received:
    0
    Location:
    Portsmouth, Hants
    Thought i would try my luck in here :D

    Having managed to sort the previous problem it has now lead to another issue. . . .

    If i start it up it will idle fine and rev up fine, if i stick it into gear (autobox) the idle drops but then it will not rev at all, if you take it out of gear it stays the same until you switch it off and on again, until you put it into gear again :(:(

    Any ideas ?
     
  2. discojamz

    discojamz Active Member

    Joined:
    Nov 10, 2007
    Posts:
    833
    Likes Received:
    9
    Location:
    Bristol
    sounds like a problem with your electrikery:smash:

    What motor do you have?
     
  3. *minty*

    *minty* Well-Known Member

    Joined:
    Jan 8, 2009
    Posts:
    20,630
    Likes Received:
    417
    Location:
    Up north

    Maybe he has an electric one.............. have you plugged it in :hysterically_laughi
     
  4. discojamz

    discojamz Active Member

    Joined:
    Nov 10, 2007
    Posts:
    833
    Likes Received:
    9
    Location:
    Bristol
    ha ha
    As you can tell i onlylike stuff which moves. That way its easy to find outwhat to fix/hit
     
  5. Aydena

    Aydena Active Member

    Joined:
    Feb 27, 2009
    Posts:
    122
    Likes Received:
    0
    Location:
    Portsmouth, Hants

    Yes glad you said that, today i was sat in it trying to work out what the feck was happening, turned the headlights on and hey presto it would idle in gear without cutting out, turned on the heater blower and the idle got better !! :eek:

    I recon it has something to do with me dropping the alternator a loong time ago :doh:
     
  6. demitrious1973

    demitrious1973 New Member

    Joined:
    Jan 31, 2009
    Posts:
    563
    Likes Received:
    0
    Location:
    in a mental institute
    :doh::doh: why did you do that for:D
     
  7. Aydena

    Aydena Active Member

    Joined:
    Feb 27, 2009
    Posts:
    122
    Likes Received:
    0
    Location:
    Portsmouth, Hants

    Back in the day (a month ago) when i had my old Ex AA van, i spent the day stripping the old engine and putting all the bits in the cubby box which has a shutter, one day after a rather spirited drive in said van i decided it'd be a good idea to open said shutter . . . . . its a good job i was wearing steel toe boots :D:D to say the least, i guess it would explain why it whines a bit :rolleyes::(
     
  8. Aydena

    Aydena Active Member

    Joined:
    Feb 27, 2009
    Posts:
    122
    Likes Received:
    0
    Location:
    Portsmouth, Hants
    Well i think its definatley the alternator, wipped the belt off this afternoon started it up and put it into gear and it idle'd fine. Next thing is to sort out why it idles at 2k RPM when cold :(
     
< Previous Thread | Next Thread >