1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Freelander 1 TD4 lack of power under 3k rpm

Discussion in 'Land Rover Freelander' started by websun, Aug 16, 2019.

< Previous Thread | Next Thread >
  1. websun

    websun Active Member

    Joined:
    Sep 26, 2018
    Posts:
    138
    Likes Received:
    14
    Location:
    Bradford
    Hello (again)
    I am starting to lose my patience with this one as well. I have a very strange lack of power below 2.8-3k rpm (flies off after) and feels like rattling somehow on low rpm.
    I also have a very strange feeling that as soon as I stop accelerating the car would somehow hold back, should be some inertia there.
    Also, when I go on a hill, I feel like it's pulling with some sort of heartbeat short interruptions, very strange even to explain.

    Now, I do have a Delphi tester around here and lots of tools. So far, I've changed:
    - MAF (brand new Bosch)
    - turbo (london turbos remanufactured)
    - turbo solenoid (initially Lemark then went for oemish Pierburg)
    - MAP sensor (initially Lemark when went for Pierburg again)
    - boost hose as it had no split but not far from it, rubbing there and all
    - crankcase breather (initially vortex then fluffy)
    - LP fuel pump and fuel filter (unrelated, just noisy)
    - all air hoses (silicone kit)

    Also cleaned the manifold and egr valve.

    On live data I get:
    - airflow: ~470 mg/injection
    - fuel rail pressure (high pressure): 28659 kPa
    - inlet manifold pressure: 98 kPa
    - low pressure supply: 358 kPa

    Something is quite strange as well, when I remove the oil cap I get quite some air blown out, even visible. I am not sure how much should it be, if I put my hand there is no pressure, and no oil gets shot out via the dipstick either.

    Please, any advise would be appreciated as this car now is one foot in the scrapyard and the other on a banana peal.

    Thank you
     
  2. hd3

    hd3 Well-Known Member

    Joined:
    Feb 5, 2012
    Posts:
    2,057
    Likes Received:
    241
    Location:
    bradford w.yorks
    as your 'location' states Bradford ..
    i could connect a Hawkeye ( LR specific ) diagnostic reader 'n see if that shows up what's up with the engine
    ~~~~~~~~~~~
    had an issue recently .. whereas a 'new' genuine LR part were faulty ..
    other diagnostics used read 'fuel press. plausibility' ..
    but the Hawkeye pinpointed the problem at the h.p. pump regulator .. it were sticking
    ~~~~~~~~~~~
    PM me if you want

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
  3. websun

    websun Active Member

    Joined:
    Sep 26, 2018
    Posts:
    138
    Likes Received:
    14
    Location:
    Bradford
    Sounds about right, I've sent you a PM. Thank you
     
  4. hd3

    hd3 Well-Known Member

    Joined:
    Feb 5, 2012
    Posts:
    2,057
    Likes Received:
    241
    Location:
    bradford w.yorks
    btw: have you checked the fuel-rail-sensor plug/socket for corrosion/grime .. ?
    be a known issue with fl1 td4's .. i.e water ingress to that plug/socket ..
    and can cause all sorts of strange running issues
    ~~~~~~~~~~~~
    ok .. just noticed your post .. will go read PM
    ~~~~~~~~~~~~~
     
  5. websun

    websun Active Member

    Joined:
    Sep 26, 2018
    Posts:
    138
    Likes Received:
    14
    Location:
    Bradford
    I did, looks brand new either corrosion did not reach it or somebody has been there before....
     
  6. websun

    websun Active Member

    Joined:
    Sep 26, 2018
    Posts:
    138
    Likes Received:
    14
    Location:
    Bradford
    Ok, met up with Simon, we did some testing, and these are the values we got:

    Fuel compensation:
    - Cylinder 1: 0
    - Cylinder 2: 0.2
    - Cylinder 3: 0.3-0.5
    - Cylinder 4: 1.4

    Cylinder roughness:
    - Cylinder 1: 780
    - Cylinder 2: 780
    - Cylinder 3: 774
    - Cylinder 4: 780

    MAF reports 450mg/injection goes up to 800 IIRC
    Manifold pressure reports ok
    HP Pump reports well 28k

    However, the low pressure pump drops to 290 kPa on acceperation, and starts with 350. Simon's car starts with 390 and never goes below 340.
    Did not have the chance to fit the Pierburg pump yet, currently it's the cheap bearmach noisy one. Other than that no idea what could cause almost power below 2500 rpm.
     
  7. websun

    websun Active Member

    Joined:
    Sep 26, 2018
    Posts:
    138
    Likes Received:
    14
    Location:
    Bradford
    Fixed, found my issue. There was huge split on the base of the hose in red circle area due to rubbing and 90 degree travel. Found it when I was blanking my egr.
    Car runs excellent now. Thanks everyone especially hd3 for the help.

    upload_2019-8-17_19-44-11.png
     
< Previous Thread | Next Thread >