1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Rear wiper -diesel

Discussion in 'Range Rover' started by kapilamuni, Aug 7, 2017.

< Previous Thread | Next Thread >
  1. kapilamuni

    kapilamuni Active Member

    Joined:
    Sep 9, 2011
    Posts:
    550
    Likes Received:
    43
    Hi all,
    Rear wiper was working very slow and it stopped completely in the middle. Following day morning noticed that the battery was half dead and thought that wiper 'auto parking' was trying to get it parked , hence the battery drain. Removed fuse 15 & charged the battery no more battery draining. With fuse 15 gone, no interior lights & rear lower door lock functions. However, noticed that whenever I open a door the interior lights come on, momentarily. How can this be, as the fuse-15 is the sole power supplier to interior lights / rear wiper circuit?
    Could not check the connections at rear wiper , yet.
    your advise is appreciated, as this could be the culprit on my battery drain.
     
  2. kapilamuni

    kapilamuni Active Member

    Joined:
    Sep 9, 2011
    Posts:
    550
    Likes Received:
    43
    No one?:confused::confused:
    o_O
     
  3. davcud

    davcud Well-Known Member

    Joined:
    Jun 20, 2013
    Posts:
    2,929
    Likes Received:
    233
    Location:
    Bolton
    Just a suggestion disconnect rear wiper completely, re fit fuse, see what happens, if all ok it sounds like the wiper motor fubar
     
  4. kapilamuni

    kapilamuni Active Member

    Joined:
    Sep 9, 2011
    Posts:
    550
    Likes Received:
    43
    Done but it drains the battery. Must be something with the interior light circuit.
     
    Last edited: Aug 8, 2017
  5. Grrrrrr

    Grrrrrr Jedwood Spannerhands

    Joined:
    Jul 8, 2012
    Posts:
    12,895
    Likes Received:
    3,172
    Location:
    Buckinghamshire, UK. ('95 DT)
    Sounds like it is earthing somewhere else.

    My rear nearside passenger interior light hasn't worked in ages. Fuse fine and bulb and indeed the light unit. So must be a wire or connector gone somewhere. No battery drain though and wiper works fine.
     
  6. kapilamuni

    kapilamuni Active Member

    Joined:
    Sep 9, 2011
    Posts:
    550
    Likes Received:
    43
    Even after I remove the fuse 15, the interior lights blip momentarily whenever I open a door.
    Means that it's getting power from something else.:confused:
     
    Grrrrrr likes this.
  7. Grrrrrr

    Grrrrrr Jedwood Spannerhands

    Joined:
    Jul 8, 2012
    Posts:
    12,895
    Likes Received:
    3,172
    Location:
    Buckinghamshire, UK. ('95 DT)
    I need to check the wiring diagram but I suspect it is permanently live and earths in order to come on. If so, it is finding an earth somewhere which with you opening the door might be a chafed wire or similar.
     
  8. wammers

    wammers STILL BREATHING. Donater

    Joined:
    Oct 19, 2008
    Posts:
    56,751
    Likes Received:
    10,706
    Location:
    Preston Lancs.
    Lamps/wiper are switched and controlled by BECM. I would think the fault is with the wiper motor.
     
  9. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
    When my front windscreen wiper motor was faulty it caused all sorts of electrical error messages on dash display and strange wiper behaviour
     
  10. kapilamuni

    kapilamuni Active Member

    Joined:
    Sep 9, 2011
    Posts:
    550
    Likes Received:
    43
    Though I disconnected the wiring connector, did not check the motor with a direct supply. will do that n see. Is the wiper motor repairable?
     
  11. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
  12. tomcat59alan

    tomcat59alan Well-Known Member

    Joined:
    Apr 3, 2011
    Posts:
    11,547
    Likes Received:
    2,839
    Location:
    wirral and triquivijate
  13. SpanishTony

    SpanishTony Active Member

    Joined:
    Sep 24, 2012
    Posts:
    297
    Likes Received:
    77
    Location:
    Cheshire
    Think Charles has moved to Wales, used both in the past
     
  14. tomcat59alan

    tomcat59alan Well-Known Member

    Joined:
    Apr 3, 2011
    Posts:
    11,547
    Likes Received:
    2,839
    Location:
    wirral and triquivijate
    I did wonder, saw something on the bay and it looked like one of his listings but the address was Powys.:)
     
< Previous Thread | Next Thread >