Rangerover p38 electric issues

This site contains affiliate links for which LandyZone may be compensated if you make a purchase.
Posts
20
Location
New Zealand
Hi I have a 2002 rangerover p38. Radio, and heater unit is not working. No power to them. Power is getting through the main fuses and the fuse in back of radio is not blown. Does any one know of any wiring diagrams that could help or any ideas of what my issue could be.

Cheers Riley
 
Hi I have a 2002 rangerover p38. Radio, and heater unit is not working. No power to them. Power is getting through the main fuses and the fuse in back of radio is not blown. Does any one know of any wiring diagrams that could help or any ideas of what my issue could be.

Cheers Riley
Full wiring diagrams are in RAVE the workshop manual which I think can be downloaded from a link in the tech archive.
It could well be a problem with the fuse box which is quite common.
 
Hi I have a 2002 rangerover p38. Radio, and heater unit is not working. No power to them. Power is getting through the main fuses and the fuse in back of radio is not blown. Does any one know of any wiring diagrams that could help or any ideas of what my issue could be.

Cheers Riley

One lot of fuses (and relays) under the bonnet and another lot under the driver's seat.
 
have you checked relay 7
 

Attachments

  • Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-135.png
    Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-135.png
    263.7 KB · Views: 117
see attached
 

Attachments

  • RADIO.png
    RADIO.png
    836.5 KB · Views: 109
  • Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-133.png
    Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-133.png
    849.2 KB · Views: 118
  • Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-150.png
    Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-150.png
    205.2 KB · Views: 114
  • Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-137.png
    Electronic Troubleshooting Manual RR-P38 (LRL0086ENG)-137.png
    374.5 KB · Views: 107
Replaced a bit of leak off pipe. It was a piece of the cheap stuff from Island4x4 I put on injector #6. It lasted 1 year. Replaced with the Gates reinforced stuff and washed all the diesel off. 300 miles with a pinhole chucks quite a lot out.
 
Have checked all fuses and relays again. On back of radio only the 2 purple wires have power. Which other ones should ? Is there any fuses on the back of the amp that might affect this? And does the power come from the bcem?
 
which radio do you have low ,medium or high, the purple is a permanent supply to hold the memory its the white/pink that activates the radio via the ignition hence the test A check looks for these .you can try a temporary link to the white/pink from the purple and this should fool the radio into thinking it has it's ignition supply . then its a matter of tracing the ignition fed white/pink (possibly a BCU problem) back .
 
Have checked all fuses and relays again. On back of radio only the 2 purple wires have power. Which other ones should ? Is there any fuses on the back of the amp that might affect this? And does the power come from the bcem?

iirc it is the same fuse as the cigarette lighter and the clock so if they're working then the radio should have power. As the purple has power I suspect not the fuse.
 
Back
Top