1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Meridian stereo issue

Discussion in 'Land Rover Freelander' started by stt, Aug 28, 2021.

< Previous Thread | Next Thread >
  1. stt

    stt Member

    Joined:
    Oct 30, 2008
    Posts:
    13
    Likes Received:
    0
    I have recently bought a 2014 HSE with the meridian audio setup and there are a couple issues.
    There is a random static “click” that comes from the speakers - it’s irrespective of the source or even volume, if the sound is muted the noise still appears - I’m guessing it’s an amp issue but I have no knowledge beyond that - I don’t even know where it’s located or if indeed it’s a separate unit.

    the second issue relates to the sat nav - sometimes (again randomly) the map disappears and just leaves a black screen, the text overlay is still there and it still plots and directs you at junctions.

    can anyone shed any light on these problems and can anyone recommend someone in the south west that could rectify them?

    thanks
     
  2. Nodge68

    Nodge68 Well-Known Member

    Joined:
    Nov 15, 2011
    Posts:
    25,553
    Likes Received:
    6,745
    Location:
    Near Newquay
    It sounds like it could be an amplifier issue, but really you need to have a diagnostic read done, to see if it flags up an issue.
    I'm not sure about the later systems, but the early FL2 amplifier is behind the RH boot side panel.
     
< Previous Thread | Next Thread >