1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

LED indicator conversion

Discussion in 'General Land Rover Forum' started by Clambod, Aug 20, 2019.

< Previous Thread | Next Thread >
  1. Clambod

    Clambod New Member

    Joined:
    Mar 9, 2019
    Posts:
    3
    Likes Received:
    0
    Location:
    Winsford, cheshire
    Hi, I recently bought a Wipac kit to swap the side/ tail lights and indicators to LEDs. the side and tail lights were a straight swap and worked well. i swapped the indicators to LED units. and replaced the flasher relay (4 pin) for the one that came in the kit (3 pin). When I used the indicator all four flashed. As the hazard switch, through wich the indicator wiring goes (same as a mini), I replaced the hazard switch and the indicator unit on the steering column. When the indicators was switched on, again all four flashed. The green panel light showing a trailer also was illuminated the whole time.
    To cut a long story short i replaced the LED indicator units for new standard bulb type. I replaced the flasher unit and now everything works fine.
    Can anyone explain why there is such a problem changing to LEDs
     
  2. Hicap phill

    Hicap phill Well-Known Member

    Joined:
    Dec 30, 2017
    Posts:
    6,405
    Likes Received:
    7,370
    Location:
    Wiltshire
    Hi
    Guessing you have an early defender?

    You may need 1 of the attached.from bolt on bits
    (It’s all to do with earths)
    Thanks
    5D39E654-EAA6-4645-9761-4802A0C363D3.png
     
  3. Nodge68

    Nodge68 Well-Known Member

    Joined:
    Nov 15, 2011
    Posts:
    19,212
    Likes Received:
    3,955
    Location:
    Near Newquay
    LEDs use less power, so the flasher unit gets upset, thinking a bulb has failed.

    Be aware that LEDs in standard lamp units are now an MOT fail.
     
  4. Clambod

    Clambod New Member

    Joined:
    Mar 9, 2019
    Posts:
    3
    Likes Received:
    0
    Location:
    Winsford, cheshire
    Yes you are right it is a '87 defender 90 but with 200TDI Mk1 Discovery engine.

    thank you for the information. I suspected there was leakage between the two sides but it would be difficult (and expensive) to fix
     
  5. Hicap phill

    Hicap phill Well-Known Member

    Joined:
    Dec 30, 2017
    Posts:
    6,405
    Likes Received:
    7,370
    Location:
    Wiltshire
    I done the same conversion with wipac kit & found the problem. I cut a cable to prove a fault & the indicators worked fine.
    Fitted the dash bulb as above reconnected the cable and all is fine.

    (Make sure you lube the glass fuse holders as this can cause problems later in life)
     
< Previous Thread | Next Thread >