1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Courtesy lights not working

Discussion in 'Land Rover Freelander' started by Staffsstormspotter, May 24, 2014.

< Previous Thread | Next Thread >
  1. Staffsstormspotter

    Staffsstormspotter New Member

    Joined:
    May 24, 2014
    Posts:
    5
    Likes Received:
    0
    bought my landy a couple of months ago (freelander 1 td4 2.0d auto) and one of those littlr annoying things was the interior courtesy light not working. so as its raining I thought I'd have a look. Went to Halfords and got some bulbs! Had a look at The Haynes manual...simple enough.

    small flathead driver later and I'd chaned the bulbs (didnt look like they'd blown but changed them anyway!)...still didnt work, so pulled the unit out from the roof and saw the problem. theres nothing connecting the wiring plug to the unit. (see pics)

    so the question is, is this a simple wire missing or do I need to buy something?

    thanks in advance for any help

    Chris
     

    Attached Files:

  2. Brack

    Brack Well-Known Member

    Joined:
    May 19, 2012
    Posts:
    1,635
    Likes Received:
    10
    Location:
    North East
  3. teddywood1

    teddywood1 Well-Known Member

    Joined:
    Jul 7, 2011
    Posts:
    5,554
    Likes Received:
    302
    Location:
    stoke-on-trent
    yes your circuit board is missing
     
  4. Staffsstormspotter

    Staffsstormspotter New Member

    Joined:
    May 24, 2014
    Posts:
    5
    Likes Received:
    0
    Thanks. There's a circuit board with the switches. Is (should) there be another one as well?

    Thanks

    Chris
     
  5. griff2

    griff2 Active Member

    Joined:
    Dec 25, 2013
    Posts:
    694
    Likes Received:
    4
    Location:
    STAFFORD UK
    from the circut where the switches are there should be a cable that runs from them under a sponge protective panel ,under that there should be a very basic circut board

    mine had some solder missing ,i just cleaned and resoldered now works 100 % very easy fix
     
  6. Staffsstormspotter

    Staffsstormspotter New Member

    Joined:
    May 24, 2014
    Posts:
    5
    Likes Received:
    0
    Great thanks for confirming. Off to ebay to find a replacement.

    Chris
     
< Previous Thread | Next Thread >