1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

battery drain fuse 49

Discussion in 'Range Rover' started by Mercedeschris, Feb 27, 2018.

< Previous Thread | Next Thread >
  1. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,615
    Likes Received:
    879
    Location:
    Kent
    Thirds !!, don't get me involved :mad:
     
  2. tomcat59alan

    tomcat59alan Well-Known Member

    Joined:
    Apr 3, 2011
    Posts:
    10,074
    Likes Received:
    1,774
    Location:
    wirral and triquivijate
    Involve me out too.;)
     
  3. Mercedeschris

    Mercedeschris Member

    Joined:
    Feb 27, 2018
    Posts:
    14
    Likes Received:
    1
    Location:
    Bolton
     
  4. Mercedeschris

    Mercedeschris Member

    Joined:
    Feb 27, 2018
    Posts:
    14
    Likes Received:
    1
    Location:
    Bolton
    Hi all

    Anybody had L322 2004 BCU issues? My car has the following systems inoperative::...... No interior lights, no remote CDL, no windscreen washers (wipers work) no heated seats, no heater control panel, EAS inop.
    Andy kindly sent me all the RAVE manuals, which lead me to the BCU being faulty as all these items are passed through it. That said I don't like replacing sensitive ECUs without some sanity checks from similar owners.

    Is T4 diagnostics mega money as this is mentioned in the RAVE manual......I have Snap-On Solus at my disposal but it doesn't seem to be much help?? for £4500!!

    Thanks for all feedback so far. much appreciated.

    I'll start RAVING of a different kind if I fix this car.. LOL
     
  5. Saint.V8

    Saint.V8 Dyed-in-the-wool 100% RR Junkie

    Joined:
    Apr 27, 2008
    Posts:
    15,381
    Likes Received:
    1,468
    Location:
    Surrey - Near the middle, close to some green bits
    Take the 4.5k....treble it and you will get a fully fledged T4 Testbook......

    Faultmate extreme is cheaper and just as powerful, but you are still looking at over a K for that probably.

    I would suggest it could be a databus fault, but the items mentioned are on different buses....so, hmmmmm

    The instrument pack acts as a gateway and ties the databuses together, it could be in there....

    Best this is to get it on decent diagnostics, and use the computer to actuate the items not working to check if it is indeed a databus issue, ecu issue or a peripheral issue (i.e. The washer motor doesn'tactually work)
     
  6. Mercedeschris

    Mercedeschris Member

    Joined:
    Feb 27, 2018
    Posts:
    14
    Likes Received:
    1
    Location:
    Bolton
    Thanks for that. I'll see what other diagnostics I can call on. as the snap on thing seems useless..
    I was originally investigating a SAT NAV issue which I've fixed now. Sure these other systems were OK previously? I've re traced my steps to see if anything disconnected but no joy.
    I'll get it plugged and update. I'm always cautious of so called "plug in experts" as some charge a fortune to metaphorically speaking look at your watch then tell you the time.


    Cheers
     
    Mark Piercy likes this.
  7. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,615
    Likes Received:
    879
    Location:
    Kent
    Have you checked the BCU for anything untoward like a loose connection?
    Ant has a good point regarding the instrument pack but in the absence of RR specific diagnostic it is going to make things difficult, the Allcomms was always a favourite on here but the GAP IID is also popular.
    You could try a hard reset i guess, never tried it as mine doesn't like having the battery disconnected and if you are going to disconnect the battery then you need to follow the procedure of letting the systems shut down including your shat nav or that can die.
    Have a google L322 hard reset, there are threads on here, it might trip some of your systems out of their hissy fit
     
< Previous Thread | Next Thread >