1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

200tdi struggle to start & wont rev

Discussion in '200 TDi' started by Ruari, Jan 8, 2015.

< Previous Thread | Next Thread >
  1. Ruari

    Ruari Active Member

    Joined:
    Mar 17, 2010
    Posts:
    281
    Likes Received:
    0
    Location:
    North Ayrshire
    My Mates 200tdi starts but cuts out immediately unless the throttle is pressed. Once running it ticks over (maybe a bit rough but not serious) but when you rev it - it doesn't reach its full potential.

    Any thoughts?

    I'm thinking fuel - filter maybe lift pump?
     
  2. blue beasty

    blue beasty Leaks an prone to bits dropping off

    Joined:
    Jun 10, 2007
    Posts:
    55,134
    Likes Received:
    20,746
    Location:
    Gloucestercotshirewolds
    Could be lift pump but stick a new filter on first, it could easily be just that
     
  3. trax

    trax . Events Planner

    Joined:
    May 4, 2012
    Posts:
    10,639
    Likes Received:
    113
    Location:
    Oxfordshire
    or clogged filters, in tank, inlet of pump.. or kinked hose, hole in hose

    he run veg?
     
  4. Ruari

    Ruari Active Member

    Joined:
    Mar 17, 2010
    Posts:
    281
    Likes Received:
    0
    Location:
    North Ayrshire
    Thanks guys, that confirms what I said to him. He's complained its low on power since he got it. But He's never serviced it. Filters first.
     
  5. trax

    trax . Events Planner

    Joined:
    May 4, 2012
    Posts:
    10,639
    Likes Received:
    113
    Location:
    Oxfordshire
    if that's the case, change the air one as well and check the turbo pipes internals are all good and it has not leaks.
     
    Last edited: Jan 8, 2015
  6. lynall

    lynall Well-Known Member Full Member

    Joined:
    Feb 28, 2011
    Posts:
    15,656
    Likes Received:
    10,150
    Location:
    Current
    Bet its got an air leak somewhere in the fuel lines before the lift pump
    They run fine just slightly down on power with a dead lift pump.
    Simple thing is the throttle reaching the stop on the inj pump when pedal to the floor?
     
< Previous Thread | Next Thread >