1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

L322 2003 Range Rover Vogue

Discussion in 'Range Rover' started by Kingie, May 16, 2019.

< Previous Thread | Next Thread >
  1. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Hi All
    Wonder if anyone can help with the problem im having with my L322 Ranger Rover v8 4.4.
    The Air suspension works on minute then get in it again and not working ... No lights on the height level ...on Dash says Air suspension inactive, turn steering wheel left then right then back to middle still nothing also have noticed the steering wheel stops going in and out when the air suspension is not working then when it does work the steering wheel comes in and out ?
    Any ideas as what can be please.
    Gary
     
  2. donp38

    donp38 Well-Known Member

    Joined:
    Oct 27, 2011
    Posts:
    1,001
    Likes Received:
    13
    Have you a fully charged battery?
    Any other symptoms?
     
  3. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Hi
    Got new Battery .... have noticed the front windscreen washer has stopped working ... but rear working fine .....
    Cheers
    Gary.
     
  4. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,852
    Likes Received:
    1,018
    Location:
    Kent
    Needs diagnostics , could be many things
     
  5. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Morning
    Just ordered a iCarsoft hopefully this will help find problem ..... serviced the air Compressor yesterday ..... are these icarsoft Diagnostic good do you no?
    Cheers
    Gary.
     
  6. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Well Plugged in the icarsoft ..... Faults
    0x0084 suspension can error
    0x0004 Rear Left wheel speed sensor ... drove with Tester attached was showing speed ok ?
    0x0054 Temporary system Deactivation
    Chime T1 T2 T3
    And Fault code P00fe
    Icarsoft wouldn't connect to Air suspension saying Fault with connecting To ECU ..... but worked ok on all others ?
    Im stumped lol lol .....
    Now got no interior lights .... check all bulbs changed one blown one ..... still not working fuse ok .... seems no power getting to them .....
     
    Last edited: May 24, 2019
  7. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,852
    Likes Received:
    1,018
    Location:
    Kent
    @Saint.V8 has made a video of the icarsoft , I think it is quite good for the money.
    Did you clear all faults and rescan ?
     
  8. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Morning
    Cleared all faults but some Failed to clear she is now booked in to the Range rover Medical centre next week ..... so hopefully will be all sorted .... will update.
    Thanks for your help.
    Gary.
     
  9. Saint.V8

    Saint.V8 Dyed-in-the-wool 100% RR Junkie

    Joined:
    Apr 27, 2008
    Posts:
    16,142
    Likes Received:
    1,971
    Location:
    Surrey - Near the middle, close to some green bits
    Which failed to clear?
     
  10. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Hi
    Air suspension inactive
    Interior light Fuse ... test all fuses all fine all bulbs one blown replaced
    Rear left wheel speed sensor
    Saying theres a short in steering wheel coloum
    Dash now started saying select Neutral
    Spoken to Landyparts Woodbridge he thinks the computer isn't talking to the vehicle ...... going in next week
    Cheers
    Gary
     
  11. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    Hopefully im using the icarsoft rite .... now have ABS Amber light on, a little yellow light sort of triangle with a i in it ..... lol lol
     
  12. myfirstl322

    myfirstl322 Well-Known Member

    Joined:
    Dec 29, 2012
    Posts:
    17,204
    Likes Received:
    6,267
    Location:
    Geroutavit.....
    You mean an !
     
  13. Kingie

    Kingie Member

    Joined:
    Apr 24, 2007
    Posts:
    12
    Likes Received:
    0
    Location:
    Woodbridge
    O Dear .....
     
< Previous Thread | Next Thread >