1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Up date

Discussion in 'Land Rover Freelander' started by tincan, Jan 21, 2016.

< Previous Thread | Next Thread >
  1. tincan

    tincan Active Member

    Joined:
    Aug 1, 2008
    Posts:
    306
    Likes Received:
    0
    Location:
    devizes
    Hi all been having a few problems lately with the hippo it's been to 4 garages now 1 said turbo 1 said something about crank censor the other 2 admitted they didn't have a clue now the symptoms are when it's hot and you are trying to accerate there is a clicking sound it's very metalic sounding and black smoke let off a little sound goes and so does the smoke the sound is like a football rattle and all so I don't know if it's conected but when you turn it off and leave for around an hour it fires up first time but sluggish and lumpy as he'll no fault codes and no lights on the dash it's a td4 just wondered what your thoughts were before I have to get rid many thanks
     
  2. digby

    digby Active Member

    Joined:
    Aug 2, 2012
    Posts:
    502
    Likes Received:
    17
    Location:
    France
    Could be injector related maybe

    Do you have any diagnostic reports ???
     
  3. tincan

    tincan Active Member

    Joined:
    Aug 1, 2008
    Posts:
    306
    Likes Received:
    0
    Location:
    devizes
    all 4 garage's plugged in there box of tricks nothing shown no codes at all so maybe a leak back test to discount the injectors???
     
  4. tincan

    tincan Active Member

    Joined:
    Aug 1, 2008
    Posts:
    306
    Likes Received:
    0
    Location:
    devizes
    hi all just thought i would report back the hippo is fixed it took 4 new injectors no more lumpyness no more diesel knock but after 200000 miles you would sort of expect it looking forward to the next 100000 lol
     
  5. Lowbank

    Lowbank Active Member

    Joined:
    Jan 8, 2016
    Posts:
    317
    Likes Received:
    44
    Location:
    Burnley, lancashire
    Thank you for the feedback, there are loads of threads where either people got it fixed and then didnt post to say what fixed it or maybe they gave and sold it.
    either way we dont get maximum benefit from these threads if people dont post what actually fixed the car, so thank you
     
  6. redwood

    redwood Active Member

    Joined:
    Sep 16, 2015
    Posts:
    178
    Likes Received:
    17
    Location:
    swansea
    glad you got it sorted, incidental, did you fit brand new injectors or refurbished ones.
     
  7. tincan

    tincan Active Member

    Joined:
    Aug 1, 2008
    Posts:
    306
    Likes Received:
    0
    Location:
    devizes
    brand new thought about going down the referb route but i thought the original items lasted 200tho maybe the new ones could last the same:rolleyes: stranger things have happened
     
< Previous Thread | Next Thread >