1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Td5 discovery starting problem

Discussion in 'Land Rover Discovery' started by Bailey3610, Jan 23, 2022.

< Previous Thread | Next Thread >
  1. Bailey3610

    Bailey3610 New Member

    Joined:
    Jan 23, 2022
    Posts:
    2
    Likes Received:
    0
    Location:
    Somerset
    Hi looking for some advice or if anyone has had the same problems.
    A few weeks ago the battery died in my disco so first thing I did was attempted to jumpstart it to which it refused to even crank over even when tried with multiple vehicles. So took the battery off the truck and charged battery over night put it back on fired straight up works fine. After running it for 30 mins ish then turned it on and off a few times still had no hesitation to start perfect. So next day I go out to the truck and nothing all the light all the noises except any cranking so I done the same again took battery off and charged it up and so on… meanwhile i went and bought a brand new battery assuming maybe the battery was at fault and put the new battery on, nothing. The only was I can start the disco is by disconnecting the battery letting it drain all residule power from the ecu etc, and then starting with a freshly charged battery a hour or so later. Any help or suggestions appreciated thanks
     
  2. Railman

    Railman Member

    Joined:
    May 13, 2007
    Posts:
    15
    Likes Received:
    0
    Is it the imobiliser thats stopping you from starting? Lots of information on immobiliser problems in the forum or You tube.
     
  3. Bailey3610

    Bailey3610 New Member

    Joined:
    Jan 23, 2022
    Posts:
    2
    Likes Received:
    0
    Location:
    Somerset
    I thought the same myself that it might be immobiliser at fault but then once it has a fresh battery it starts and runs fine multiple times it’s only after left for 5 mins or so with key out and door shut that it then won’t start again
     
< Previous Thread | Next Thread >