1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Rough start

Discussion in 'TD5' started by Phanc60844, Jan 18, 2021.

< Previous Thread | Next Thread >
  1. sierrafery

    sierrafery Well-Known Member

    Joined:
    Jun 30, 2007
    Posts:
    15,378
    Likes Received:
    2,786
    Location:
    Arad
    Charge well the battery and next time run the 5 pedal purge trick before you attempt to start it and if it starts well after that then first replace the air bleed valve in the filter head and if no improvement it's time for injector copper washers IMO, would be good to replace the main relay(R9) with a new one as well. Check coolant temp and fuel temp before the cold start, they should be the same in the morning
     
    tilly2 likes this.
  2. tilly2

    tilly2 Well-Known Member

    Joined:
    Jul 28, 2019
    Posts:
    756
    Likes Received:
    304
    Location:
    Staffordshire
    Now, that second video is what mine does now and again. Its had new air purge valve, filter, and one way fuel rubber valve replaced...
     
  3. Mario110

    Mario110 Active Member

    Joined:
    Nov 12, 2018
    Posts:
    104
    Likes Received:
    3
    Location:
    Germany
    Battery was fully charged, also bleeding with pedal purge trick, nothing helped. Copper washers are new (1 year), also tried a different set of injectors. Fuel temp is always 1°C above coolant temp when I start. I will try a new main relay, because this one is not new.
     
  4. sierrafery

    sierrafery Well-Known Member

    Joined:
    Jun 30, 2007
    Posts:
    15,378
    Likes Received:
    2,786
    Location:
    Arad
    OK but is that a new(ish) strong enough battery ?
     
  5. Mario110

    Mario110 Active Member

    Joined:
    Nov 12, 2018
    Posts:
    104
    Likes Received:
    3
    Location:
    Germany
    Good question, it's noname battery it has 100Ah and cold start current of 800A....The battery is 2 year old....
     
    Last edited: Jan 25, 2021
  6. tilly2

    tilly2 Well-Known Member

    Joined:
    Jul 28, 2019
    Posts:
    756
    Likes Received:
    304
    Location:
    Staffordshire
< Previous Thread | Next Thread >