1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Lumpy Idle and smoke on starting

Discussion in 'Land Rover Freelander' started by James., Jul 18, 2012.

< Previous Thread | Next Thread >
  1. James.

    James. Member

    Joined:
    Sep 8, 2010
    Posts:
    55
    Likes Received:
    1
    Location:
    Ferndown, Dorset
    Rev needle moves about 10mm up and down when starting with white smoke, once started runs ok until you come to lights ect and idle is erratic again but not as bad .. maybe 5mm.

    Got her booking into a garage on monday so they can remove and test injectors, but im not so sure... could it be fuel pressure sensor/harness instead? :confused:

    Serviced in May
    EGR Fitted
    BMW breather crank filter fitted
     
  2. Richard Martin

    Richard Martin Well-Known Member

    Joined:
    Jan 17, 2009
    Posts:
    1,363
    Likes Received:
    8
    Location:
    Cardiff
    Yes, could be injectors or fuel pressure sensor/harness instead. If the garage is any good they should be able to work it out
     
  3. James.

    James. Member

    Joined:
    Sep 8, 2010
    Posts:
    55
    Likes Received:
    1
    Location:
    Ferndown, Dorset
    Went to LR Indi Yesterday and we plugged her in and No3 is at 2.6 and No4 is 2.7 .. so hes going to test them and probably be replacing No3 as thats the problem one and then causing No4 to be high apparently.
     
  4. ryanft58

    ryanft58 New Member

    Joined:
    Jul 27, 2012
    Posts:
    20
    Likes Received:
    0
    sounds very similar to mine, indy replaced injector and has improved the problem but still have a slight movement in the reves on first start up
     
  5. James.

    James. Member

    Joined:
    Sep 8, 2010
    Posts:
    55
    Likes Received:
    1
    Location:
    Ferndown, Dorset
    had injector 3 changed for a recon one and now alot better but still a little lumpy and smoky on first start, but doesnt do it again until next cold start. so im happier
     
  6. ryanft58

    ryanft58 New Member

    Joined:
    Jul 27, 2012
    Posts:
    20
    Likes Received:
    0
    yep had my number 3 injector replaced as well and now only get the problem on first start up or if i have left the car over long periods. i will get down to the bottom of this
     
< Previous Thread | Next Thread >