1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

L322 Bmw 4.4 v8

Discussion in 'Range Rover' started by Christianp, May 19, 2019.

< Previous Thread | Next Thread >
  1. Christianp

    Christianp New Member

    Joined:
    May 19, 2019
    Posts:
    4
    Likes Received:
    0
    Location:
    Gibraltar
    Hi everyone I have recently brought a L322 v8 4.4 Bmw engine...... ok so guy I brought from said the spark plugs needed changing that’s why engine light was on me being from Gibraltar thought he’ll be honest as we are such a small place. I changed all spark plugs and one ignition coil as one seemed broken soo after reading up also found oil in the spark plugs and read here to Change valve cover gaskets so did that too now seems to be running worse tho seems to be burning oil and engine light still on any help would be great full planing on swapping all the ignition coils on Friday just to be safe but I there anything else I could do before I consider taking it to Land Rover and getting a massive bill ?? B827B500-7CA6-45ED-AA31-04947C990D65.jpeg CE0724EC-1E4B-4C36-B4E7-66A5D027244E.jpeg 3191ACA2-8E37-47C5-9CBF-5A3ED2B0F146.jpeg 5663DB4C-D931-47BE-90B8-DBB317D9F317.jpeg 16114DB0-E123-49BE-B7CC-F24853057FAB.jpeg CE0724EC-1E4B-4C36-B4E7-66A5D027244E.jpeg
     
  2. donp38

    donp38 Well-Known Member

    Joined:
    Oct 27, 2011
    Posts:
    1,001
    Likes Received:
    13
    you could have a faulty plug, not clicked on the coils / lead properly?
    Maybe check cylinder 8 plug/coil/lead?
    Maybe swap coil over from another one and see if the fault moves, same with spark plug.
    ??
    Best of luck
     
  3. Christianp

    Christianp New Member

    Joined:
    May 19, 2019
    Posts:
    4
    Likes Received:
    0
    Location:
    Gibraltar
    Hi all so you all know two coils weren’t working and changed valve cover gaskets! Should be picking her up tomorrow. Also has a o2 sensor fault if anyone knows where I can get best let me know thanks !
     
< Previous Thread | Next Thread >