1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

HEVAC issues

Discussion in 'Range Rover' started by ThatchP38, Nov 4, 2021.

< Previous Thread | Next Thread >
  1. ThatchP38

    ThatchP38 Member

    Joined:
    Oct 11, 2021
    Posts:
    17
    Likes Received:
    9
    Location:
    United States
    Still working on the 2002 P38. I have previously posted and fixed the ABS issue with a new (used) fuse box replacement, all is good there.

    I have replaced the broken heater core using the short cut method.
    My issue is with the hevac control unit. Mine did nothing basically and did not light up but the seat heaters and windscreen heaters work.
    I replaced the unit with a used one which works nicely but I lost the seat heaters and windscreen heaters. So I put the old one back in and both things would not work and the light would not come on above the buttons.

    I checked fuses and relays and still nothing.

    Any ideas? Maybe the wiring came loose at the pins?
     
  2. Grrrrrr

    Grrrrrr Technician, Bodgit & Scarper Ltd Full Member

    Joined:
    Jul 8, 2012
    Posts:
    16,437
    Likes Received:
    6,483
    Location:
    Buckinghamshire, UK. ('95 DT)
    Was the part number the same? There were an awful lot of iterations. Marty_uk did a very good summary in the Technical Section somewhere.
     
  3. ThatchP38

    ThatchP38 Member

    Joined:
    Oct 11, 2021
    Posts:
    17
    Likes Received:
    9
    Location:
    United States
    I'll check again. I didn't look that carefully...
     
  4. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    38,208
    Likes Received:
    5,315
    Location:
    Near Poitiers SW France
    Time to get the DVM out. Are you sure you checked all the fuses? See RAVE for fuse details. If you have all the buttons you need and the connectors match up, I think you should be OK.
     
  5. brianp38dse

    brianp38dse Well-Known Member

    Joined:
    May 13, 2014
    Posts:
    16,011
    Likes Received:
    9,151
    Location:
    heathrow
  6. ThatchP38

    ThatchP38 Member

    Joined:
    Oct 11, 2021
    Posts:
    17
    Likes Received:
    9
    Location:
    United States
    Ok I'm an idiot. I started the car and then everything worked. I didn't realize it had to be running to operate the windscreen heater and seat heaters.
    On the plus side I just had a new windscreen installed and ready for winter
     
    tomcat59alan and oakey like this.
  7. oakey

    oakey Well-Known Member Full Member

    Joined:
    Dec 26, 2010
    Posts:
    1,925
    Likes Received:
    804
    Location:
    Mull of Kintyre
    Glad is fixed
     
  8. brianp38dse

    brianp38dse Well-Known Member

    Joined:
    May 13, 2014
    Posts:
    16,011
    Likes Received:
    9,151
    Location:
    heathrow
    We live and learn:D
     
< Previous Thread | Next Thread >