1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Alternator

Discussion in 'General Land Rover Forum' started by tam cochrane, Sep 29, 2020.

< Previous Thread | Next Thread >
  1. tam cochrane

    tam cochrane Member

    Joined:
    Mar 28, 2016
    Posts:
    77
    Likes Received:
    6
    Location:
    United Kingdom
    Hi all seems like my 110 is losing charge. I have 13.6 volts going in to the battery when under normal running with no draw off it is that enough to keep the battery charged or is it a faulty alternator. I have a battery cut off switch which isolates everything when the car is not used which can be two or three days at a time.
     
  2. rob1miles

    rob1miles Well-Known Member

    Joined:
    Sep 22, 2017
    Posts:
    3,418
    Likes Received:
    1,361
    Location:
    Slough and Bath
    Get the battery checked.
     
  3. tam cochrane

    tam cochrane Member

    Joined:
    Mar 28, 2016
    Posts:
    77
    Likes Received:
    6
    Location:
    United Kingdom
    New battery
     
  4. mick 1986

    mick 1986 Well-Known Member

    Joined:
    Aug 20, 2010
    Posts:
    2,440
    Likes Received:
    740
    Location:
    Lost
    That doesn’t mean it isn’t faulty. I would expect 13.6V to keep a decent battery fully topped up.

    Have you tested the isolator? Just because your removing the key, doesn’t mean it’s actually disconnecting the battery. It could have a parasitic drain and this is making you think otherwise.
     
  5. tam cochrane

    tam cochrane Member

    Joined:
    Mar 28, 2016
    Posts:
    77
    Likes Received:
    6
    Location:
    United Kingdom
    Yes tested isolator if 13.6 is enough to keep battery up then i suppose i must have a drain when i havent used isolator which isnt often but then the battery isnt getting to totally flat just a bit slow when i havent used it for a few days and i never go very far in it anyway just thought alternator would put more then that back
     
< Previous Thread | Next Thread >