1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

3 Amigo brake light switch replacement Guide

Discussion in 'Technical Archive' started by Peco, Dec 1, 2010.

< Previous Thread | Next Thread >
  1. blingenfelter

    blingenfelter New Member

    Joined:
    May 30, 2012
    Posts:
    2
    Likes Received:
    0
    Hi,

    I have 2 of the amigos, the HDC and TC lights, and my brake lights are out, but also my windshield wipers. It started sporadically, the lights would come on and function would stop, and then the next time I started the rover up, the lights would be off and the wipers/brake lights would work. Now, the lights are on all the time and the lights/wipers are totally gone. Could the brake switch affect the wipers?

    Ben
     
  2. blingenfelter

    blingenfelter New Member

    Joined:
    May 30, 2012
    Posts:
    2
    Likes Received:
    0
    Yay. found out it's the ignition switch. $400 repair. Time to learn to replace an ignition switch. Always learning new things with this vehicle...
     
  3. Hippo

    Hippo Lord Hippo

    Joined:
    Nov 22, 2007
    Posts:
    42,699
    Likes Received:
    32,532
    I had the same problem. Intermittent failure of front wipers, rear wipers, reverse and stop lights. Failed when the engine was running intermittently, but not with engine off. Turned out to be the switch on the rear of the ignition. Certainly a lot cheaper than $400 (or what ever that is in real money). I'm wondering if you can do the same? Mines a v6 auto. Switch on rear of ignition is the plastic thing in the middle:

    [​IMG]
    DSCN1969 XEbU31V
     
    Last edited: Apr 7, 2020
  4. ScottyNic

    ScottyNic Member

    Joined:
    Jul 1, 2012
    Posts:
    40
    Likes Received:
    3
    Location:
    Shetland Islands
    Hi guys, ive got the 3 amigos on my 98 XEDi took pecos advice and checked the brake light switch cleaned it up an put it back in but still 3 amigos :(
    sometimes they come and go she brakes perfectly when the lights are on but when they go off you can hear the abs block relay clicking and when i go to brake the block is in the way and i really have to push down on the pedal to stop. after that the amigos reappear again :confused:
     
  5. Freelaner

    Freelaner Landy Driver

    Joined:
    Nov 21, 2010
    Posts:
    24,846
    Likes Received:
    191
    Location:
    Yorkshire
  6. ScottyNic

    ScottyNic Member

    Joined:
    Jul 1, 2012
    Posts:
    40
    Likes Received:
    3
    Location:
    Shetland Islands
    thanks, will try some of the suggestions in there and see if i have any luck!
     
  7. furtle

    furtle New Member

    Joined:
    Nov 17, 2011
    Posts:
    2
    Likes Received:
    0
    TD4 2006. TC and HDC lamps on and brake lights not working. Replaced brake switch with a new one and the connecting wire. The connecting wire to the loom in the car doesn't 'click' together and can slide off, so, I taped up the connection.

    Both lamps stayed on. Then found out no.2 stop lamp fuse had blown. Replaced that and all is now fine.

    Thanks all.
     
  8. crockett007

    crockett007 Active Member

    Joined:
    Feb 2, 2012
    Posts:
    318
    Likes Received:
    2
    Location:
    West Berks
    Had the same issue with 2 warning lights on. Took the switch off, checked it for continuity, seemed fine. Replaced the switch, and adjusted as per manual (pull switch out as far as it will go, depress brake pedal, refit switch and allow pedal to set the switch to the correct height...... you will hear some clicks) and hey presto, brake lights are working fine now. I have ordered a new switch anyway, but knowing about the switch adjustment was a big help.
     
  9. ryanft58

    ryanft58 New Member

    Joined:
    Jul 27, 2012
    Posts:
    20
    Likes Received:
    0
    great thread guys used this to cure my two amigos problem
     
  10. ScottyNic

    ScottyNic Member

    Joined:
    Jul 1, 2012
    Posts:
    40
    Likes Received:
    3
    Location:
    Shetland Islands
    found my front n/s abs ring to be loose, i got it refitted but my 3 amigos are still present, do they need to be reset?
     
  11. crockett007

    crockett007 Active Member

    Joined:
    Feb 2, 2012
    Posts:
    318
    Likes Received:
    2
    Location:
    West Berks
    Hi Scottynic

    I found that the problem occured when I changed the brake pads and bled the brakes...... maybe something to do with fully depressing the pedal, combined with a slowly failing switch.
     
  12. ScottyNic

    ScottyNic Member

    Joined:
    Jul 1, 2012
    Posts:
    40
    Likes Received:
    3
    Location:
    Shetland Islands
    thanks, ill get onto buying a new switch and looking at pads and discs then bleed the whole system soon, as always money is an issue
     
  13. ScottyNic

    ScottyNic Member

    Joined:
    Jul 1, 2012
    Posts:
    40
    Likes Received:
    3
    Location:
    Shetland Islands
    found the problem! the abs ring i had to weld back on had too big an air gap and that was enough to throw the sensor, 1 new CV joint later (as the old one was rusted away too much) the problem has been solved :D
     
  14. crockett007

    crockett007 Active Member

    Joined:
    Feb 2, 2012
    Posts:
    318
    Likes Received:
    2
    Location:
    West Berks
    Good times!! That may prove to be an invaluable piece of info ;)
     
  15. WLJayne

    WLJayne Well-Known Member

    Joined:
    Apr 1, 2012
    Posts:
    3,810
    Likes Received:
    13
    Location:
    Derpyshurr
    Just fitted the new switch, seems to be working fne now although one of me bulbs is going.

    Will.
     
  16. melliott

    melliott New Member

    Joined:
    Feb 13, 2012
    Posts:
    72
    Likes Received:
    0
    Location:
    North Sheffield
    Hi All
    Still having trouble with the 3 amigos, if i remove no.7 fuse the lights go out, if i remove any other ABS fuse they dont.
    Can someone please tell me what the no.7 works to try and narrow the fault down
    Thank you
    Mell
     
  17. davidstoncold

    davidstoncold Member

    Joined:
    Feb 3, 2008
    Posts:
    49
    Likes Received:
    0
    Location:
    mansfield
    i have just fitted new discs,pads ,shoes and drums to mine and the lights havent come back on for a week ..
     
  18. frontosa

    frontosa Active Member

    Joined:
    Nov 3, 2011
    Posts:
    123
    Likes Received:
    0
    Hi might have to chamge my switch, if i change do you have to get this converter harness. thanks.
     
  19. Wonkey

    Wonkey New Member

    Joined:
    Jul 28, 2012
    Posts:
    14
    Likes Received:
    0
    Location:
    London near heathrow airport
    Great post
    will try this out this week. As I too have lights on dash but no brake lights.
     
  20. crockett007

    crockett007 Active Member

    Joined:
    Feb 2, 2012
    Posts:
    318
    Likes Received:
    2
    Location:
    West Berks
    It's definitely the switch, Wonkey :)
     
< Previous Thread | Next Thread >