1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

15j 2.5na vacuum pump

Discussion in '2.5 N/A' started by sid2010, Jul 31, 2021.

< Previous Thread | Next Thread >
  1. sid2010

    sid2010 Member

    Joined:
    Aug 28, 2020
    Posts:
    31
    Likes Received:
    18
    Location:
    penrith cumbria
    I've got a series 2a with the tin timing plate Sherpa engine in it . Last week she sent a litre of oil out through the inlet manifold.
    Big panic on I new she was burning a bit of oil thought it was valve the stem oil seals so in my haste off comes the head to find all was relatively normal in good condition.
    Down to the machine shop to get it checked and skimmed and reseat the valves etc.
    I mentioned the problem to him and after a few seconds he said do you use the vacuums pump for the servo and as it's a 2a servos didn't exist so no it just sits there puffing away .
    Well apparently they can cause the crank case to pressurise and send oil back through the breather and into the inlet manifold.his suggestion is to remove the veins out of the pump and blank off the breather pipe.
    My question is can you remove the pump all together and put a plate in its place?
    Any suggestions would be appreciated
     

    Attached Files:

    Zed. likes this.
  2. Turboman

    Turboman Rural Activist

    Joined:
    Aug 21, 2010
    Posts:
    55,627
    Likes Received:
    58,019
    Location:
    Continuously Cruising
    You can do that, and it is done sometimes. I think it is usual to remove the driveshaft, and the worm gear as well.
     
  3. sid2010

    sid2010 Member

    Joined:
    Aug 28, 2020
    Posts:
    31
    Likes Received:
    18
    Location:
    penrith cumbria
    Just a quick add on to my engine problem .
    On removal of cylinder head I checked water pump discovering bad seal and bearings.
    After days of searching I discovered the correct water pump on ebay cant use the lr 2.5 na one as the belt pulley is smaller and the it sits to far forward and fan catches the radiator so no good.
    Part number for correct water pump is gwp328 and is the correct unipart item.
    So anyone in penrith area I've got a water pump bearmach stc 635 br2388 going cheap
     
  4. Blackburn

    Blackburn Well-Known Member

    Joined:
    Feb 21, 2013
    Posts:
    3,104
    Likes Received:
    628
    Location:
    Tyneside
    My 15J ran with the vacuum pump port blocked for years with it blocked it cannot suck air in so does not pressurise the sump.
     
  5. sid2010

    sid2010 Member

    Joined:
    Aug 28, 2020
    Posts:
    31
    Likes Received:
    18
    Location:
    penrith cumbria
    Lots of people have told me about this problem shame they didn't tell the last owner.
    I did take the top off and removed the plastic veins aswell as blocking the hole though.
     
< Previous Thread | Next Thread >