1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Series 3 Brake master freeplay at the push rod

Discussion in 'Series Land Rovers' started by WoodyO, Jan 14, 2022.

< Previous Thread | Next Thread >
  1. WoodyO

    WoodyO Active Member

    Joined:
    Jun 5, 2020
    Posts:
    188
    Likes Received:
    97
    Location:
    UK
    Evening all,

    Trying to get to the bottom of a brake problem.

    All new system and new cylinders recently fitted due to rust. I initially thought that is what caused my wheel bind, but with new cylinders on the problem persists.

    In short, hydraulic pressure remains in the system after brakes have been applied.

    S3 109 single line master, non servo.

    Brake pressure switch installed just off the master, brake lights staying lit so definitely not releasing pressure as it should.

    Removed the master today and popped the piston out, all looks good apart from some pitting or rust in side, see picture.

    When reassembling the master and putting the circlip back on I noticed there is no freeplay at all on the master piston with the circlip installed. The piston is probably 1 to 2mm 'inserted' into the housing, which I'm hoping is my problem.

    What I find strange is there doesn't seem to be a cause.

    I have another master here (TRW, but wrong part number) which has the correct amount of freeplay between rod and piston.

    Any ideas?

    Does anyone have a Britpart master to hand to see if there is actually any freeplay between rod and piston?

    [​IMG]
    instagram photo downloader chrome
     
  2. Bobsticle

    Bobsticle De Villes Advocaat

    Joined:
    Aug 8, 2013
    Posts:
    18,949
    Likes Received:
    22,368
    Location:
    Manchester
    Britpart you say ? o_O
     
  3. WoodyO

    WoodyO Active Member

    Joined:
    Jun 5, 2020
    Posts:
    188
    Likes Received:
    97
    Location:
    UK
    Fitted a Bearmach master cylinder today that had the correct amount of freeplay between rod and piston. As expected, brakes working fine and no bind.

    Will open another warranty claim against the Britpart master. I just can't understand how it's gone from working fine to having no freeplay at all.
     
< Previous Thread | Next Thread >