Land Rover ForumsLandrover Forum

Forum LZ Shop Gallery For Sale LZ - Live
Go Back   Land Rover Zone > Land Rover Talk > Land Rover Discovery
Register Search Today's Posts Mark Forums Read

Land Rover Discovery Got yourself a Disco? Get yourself in here! Forum Sponsored By: Mailorder4x4.com accessories & parts for your Disco Every Part Covered!

Welcome to Land Rover Zone!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, photos and use our for sale section. Registration is fast, simple and absolutely free so please, join our community today!



Reply
 
Thread Tools
  #1  
Old 3rd-June-2006, 19:09
Junior Member
 
Join Date: Jun 2006
Posts: 2
Default Flickering oil light!?

Hello. First time ive done this. I have a flickering oil warning light on my 3.5i V8 disco. Only comes on when engine is hot & idling, if I blip the throttle light goes out. Plenty of oil in it, was last changed (semi synthetic) 4,000 miles ago. Been told it COULD be oil pump gearing?? Is this an urgent problem, supposed to be towing a caravan next weekend. Any advice would be very much appreciated. Andy (N.Wales)
Reply With Quote
LZ
  #2  
Old 3rd-June-2006, 21:30
yella's Avatar
Senior Member
 
Join Date: Dec 2005
Location: outside cos every fookers in me shed and theres no room fer me
Posts: 15,991
Default Re: Flickering oil light!?

it could be the oil pressure switch. i would try that before messing with the oil pump
Reply With Quote
  #3  
Old 29th-October-2006, 09:56
Junior Member
 
Join Date: Oct 2006
Location: Warfield Berks
Posts: 3
Default Re: Flickering oil light!?

Hi Guys,
Got the exact same issue.

I am buying a 94 TDI Disco 150K miles and this is exactly what I am experiencing also, warm and idling on come the oil light.

My friend who I am buying it off says not to worry about this t happens on all Landrovers.

However, seeing the red light flash on every time the Disco idles is making me feel very nervous.

Love the vehicle, but not the red light. I can hold my own with engines but am far from technical.

If it is an oil light how easy can that be rectified? If it is something more serious, what could that be and, well what could be the damage?

I would appreaciat any perspective anyone can give. As just one spin around the block and I am completly hooked on a Landrover.

Many thanks in advance.
Reply With Quote
  #4  
Old 29th-October-2006, 10:26
donboon's Avatar
Senior Member
 
Join Date: Jul 2006
Location: dependsonwhoesasking
Posts: 145
Default Re: Flickering oil light!?

Like Yella Disco said, you must test the pressure sensor 1st. Best fit a oil pressure gauge on it but don't hold your hopes up. It's a sure sign of wear most likely from the pump but it could be any bearing surface beginning to give up. If it was me I wouldn't be towing until I knew what was causing the problem. Whatever it is you won't be doing your motor any favours by increasing the load.
Reply With Quote
  #5  
Old 29th-October-2006, 10:58
Senior Member
 
Join Date: May 2005
Posts: 5,482
Default Re: Flickering oil light!?

Quote:
Originally Posted by Mike from Warfield
My friend who I am buying it off says not to worry about this t happens on all Landrovers
- what a crock!
Reply With Quote
  #6  
Old 29th-October-2006, 11:45
Spyderman's Avatar
Senior Member
 
Join Date: Aug 2006
Location: Luton
Posts: 5,196
Default Re: Flickering oil light!?

Originally Posted by Mike from Warfield
My friend who I am buying it off says not to worry about this t happens on all Landrovers

He was probably talking about Series engines, when it is Ok for the oil light to flicker on tickover but must go out when revved. No way should it be coming on, on a Disco.
Reply With Quote
  #7  
Old 13th-March-2007, 09:29
tonyw's Avatar
Senior Member
 
Join Date: Aug 2006
Posts: 221
Default Re: Flickering oil light!?

Andy/Mike, did you fix this problem?
Reply With Quote
  #8  
Old 13th-March-2007, 18:20
cavking's Avatar
Member
 
Join Date: Oct 2006
Posts: 61
Wink Re: Flickering oil light!?

cavking vbmenu_register("postmenu_273038", true);
Junior Member
Join Date: Oct 2006
Posts: 23


Re: Oil light comes on under 1000 RPM
hi chap
i had the same oil light problem a couple of years ago, just changed the pressure sender . oil had worked its way into plastic casing causing it to short
no problems since. have a look if the white part of the sender is, internally blackened by oil
all the best, hope i have been of any help
Reply With Quote
  #9  
Old 14th-March-2007, 07:40
Member
 
Join Date: Feb 2007
Posts: 47
Default Re: Flickering oil light!?

Hi Guys,
I have just had the exact same problem develop on my 300tdi (158K) - Just got back from a couple of days away at the coast. It started coming on when I dropped the revs to get down a rather steep bank. I had checked the oil and it was showing full (when cold). Driving back home it would come on when pulling up at r'abouts etc, generally when the revs dropped below 1500, but went out when accelerating away. Then,about half hour into the 2hour journey home it came on and stayed on at all revs and speeds. I pulled over, checked the oil - no probs - gave it 5 mins and started it again - went out.
I am going to try the oil light switch first which I believe is located by the oil filter?
Other than that the engine was faultless, no smell of burning oil etc.
Just as an after thought, On it's last service , 2000 miles ago, the oil etc was changed and AMTEC engine restorer was added. It has helped restore some umph to what was becoming a tired 300 before that.
Reply With Quote
  #10  
Old 14th-March-2007, 09:06
tonyw's Avatar
Senior Member
 
Join Date: Aug 2006
Posts: 221
Default Re: Flickering oil light!?

Quote:
Originally Posted by Wrighters View Post
Hi Guys,
I have just had the exact same problem develop on my 300tdi (158K) - Just got back from a couple of days away at the coast. It started coming on when I dropped the revs to get down a rather steep bank. I had checked the oil and it was showing full (when cold). Driving back home it would come on when pulling up at r'abouts etc, generally when the revs dropped below 1500, but went out when accelerating away. Then,about half hour into the 2hour journey home it came on and stayed on at all revs and speeds. I pulled over, checked the oil - no probs - gave it 5 mins and started it again - went out.
I am going to try the oil light switch first which I believe is located by the oil filter?
Other than that the engine was faultless, no smell of burning oil etc.
Just as an after thought, On it's last service , 2000 miles ago, the oil etc was changed and AMTEC engine restorer was added. It has helped restore some umph to what was becoming a tired 300 before that.
It'll be interesting to hear what occurs with this, so please do keep us posted.
Reply With Quote
LZ
Reply

Thread Tools



All times are GMT +1. The time now is 12:44.

Content Relevant URLs by vBSEO 3.2.0
Page generated in 0.15346 seconds with 8 queries