1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

trailer brake lights

Discussion in 'Range Rover' started by stustrong, Feb 23, 2015.

< Previous Thread | Next Thread >
  1. stustrong

    stustrong Well-Known Member

    Joined:
    Oct 28, 2014
    Posts:
    921
    Likes Received:
    105
    Location:
    Aberdeenshire
    As title they dont apper to be working any worth wile checks?
     
  2. rodntod

    rodntod Active Member

    Joined:
    Dec 22, 2011
    Posts:
    607
    Likes Received:
    2
    Location:
    ayrshire scotland
    Check the pin at the towbar plug on the car that is supposed to feed the brake lights,as shown here. Get some one to press the brakes with the ign on,and you should have 12volts at the red(no.6) pin.Sometimes a good clean of the pins is all thats needed,but wiring in the plug is possibly corroded.

    Ed

    [​IMG]
     
  3. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    32,838
    Likes Received:
    1,769
    Location:
    Near Poitiers SW France
    Using a bulb for testing is best as a DVM can sometimes give a false reading due to it's very low current draw.
     
  4. stustrong

    stustrong Well-Known Member

    Joined:
    Oct 28, 2014
    Posts:
    921
    Likes Received:
    105
    Location:
    Aberdeenshire
    Got it was a iffy plug behind light cluster in the boot cheers folks
     
< Previous Thread | Next Thread >