1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

td5 fault codes

Discussion in 'Defender 90 / 110 / 130' started by carl2351, Mar 10, 2012.

  1. carl2351

    carl2351 New Member

    Joined:
    Dec 28, 2008
    Posts:
    20
    Likes Received:
    0
    my td5 is still cutting out
    ive bought a hawkeye and fault keeps coming up injector long charge fault codes 3183 3184 ect
    sometimes will celar and restart sometimes clear and then wont run more than a second and cut out with same fault any ideas
     
  2. DerekT

    DerekT Active Member

    Joined:
    Dec 1, 2011
    Posts:
    302
    Likes Received:
    1
    Location:
    Aberdeen
    What have you tried so far? Fuel supply, ECU plug, Injector seals??
     
  3. carl2351

    carl2351 New Member

    Joined:
    Dec 28, 2008
    Posts:
    20
    Likes Received:
    0
    Where do i start

    So far new loom new ecu full wiring loom fuel pump new injectors air flow meter Cylinder head

    Im at wits end
     
  4. ratty

    ratty I'm not special I'm limited edition Global Moderator

    Joined:
    Sep 18, 2007
    Posts:
    34,274
    Likes Received:
    32
    Location:
    Stuck in a ditch somewhere in Somerset
    when you say full wiring loom do you mean 'injector harness'? Or do you mean the harness AND the main wiring loom?
     
  5. eightinavee

    eightinavee Well-Known Member

    Joined:
    Jan 21, 2006
    Posts:
    3,873
    Likes Received:
    11
    Location:
    Near Bath,SW UK.
    Le ECU est Fubar.
     
  6. ratty

    ratty I'm not special I'm limited edition Global Moderator

    Joined:
    Sep 18, 2007
    Posts:
    34,274
    Likes Received:
    32
    Location:
    Stuck in a ditch somewhere in Somerset
    It sounds like the most likely scenario but I have come across the wiring loom chafing through between the battery and engine before now. There is usually signs of damage to the conduit in this area if it is the case.

    I don't suppose you know the usual place where the MAF/Throttle pot 5v feed is lost do you? I went out to a TD5 defender the other day that had hit water as speed and lost the 5v feed. I couldn't find the break at the side of the road and in the dark.:eek:
     
  7. DerekT

    DerekT Active Member

    Joined:
    Dec 1, 2011
    Posts:
    302
    Likes Received:
    1
    Location:
    Aberdeen
    Has the new ECU been programmed with the new injector parameters?
     
  8. carl2351

    carl2351 New Member

    Joined:
    Dec 28, 2008
    Posts:
    20
    Likes Received:
    0
    yes i programmed ecu and ive tried 2 anyway i had one and bought another for good measure !
    ive changed engine loom and main car loom even though i couldnt se eproblem
    there is no oil in loom
    ive tried crank sensor once think ill try another as i bought on ebay and who knows
    its all a long shot
    if this fails think i will have to abandon td5 and put 300 in which seems a big step buut cant have landrover i can only drive a few miles before failing
    surely someone can help please
     
  9. ratty

    ratty I'm not special I'm limited edition Global Moderator

    Joined:
    Sep 18, 2007
    Posts:
    34,274
    Likes Received:
    32
    Location:
    Stuck in a ditch somewhere in Somerset
    The ECU's that you've bought I take it are 'known' good ones? They're not ebay jobbies?

    There are plenty of knackered ECU's out there.
     
  10. carl2351

    carl2351 New Member

    Joined:
    Dec 28, 2008
    Posts:
    20
    Likes Received:
    0
    no not known but same fault across all ecu seems too far fetched i have my wifes td5 i guess i could try it but hers is a newer one so wouldnt work
     
  11. ratty

    ratty I'm not special I'm limited edition Global Moderator

    Joined:
    Sep 18, 2007
    Posts:
    34,274
    Likes Received:
    32
    Location:
    Stuck in a ditch somewhere in Somerset
  12. carl2351

    carl2351 New Member

    Joined:
    Dec 28, 2008
    Posts:
    20
    Likes Received:
    0
    still no solution

    will run then stop

    clue is it will then run on spare ecu

    what could cause this
     
  13. DavidJR

    DavidJR New Member

    Joined:
    Jul 7, 2009
    Posts:
    222
    Likes Received:
    0
    Get a new spare ecu and use the spare ecu to replace the faulty ecu?!
     
  14. carl2351

    carl2351 New Member

    Joined:
    Dec 28, 2008
    Posts:
    20
    Likes Received:
    0
    Well thats not answer i have spare ecu
    when it stops plug that in then it will run

    it then does same again on that ecu and by then the original ecu has sometimes 'repaired' itself

    im sure problem is staring me in the face but i cant figure it

    surely osmeone out there has had this fault before please help
     
  15. johnlad

    johnlad Well-Known Member

    Joined:
    Jan 7, 2010
    Posts:
    4,163
    Likes Received:
    69
    Location:
    Blackpool
    loose pins on ecu connection, i had same in a merc sprinter
     
  16. Shifty1962

    Shifty1962 Well-Known Member

    Joined:
    Mar 1, 2008
    Posts:
    3,986
    Likes Received:
    13
    Location:
    The Winchester Club - Englandshire
    ECU earthing point needs a clean and tighten.