1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

td5 engine cut out

Discussion in 'TD5' started by irakli_makh, Nov 15, 2011.

< Previous Thread | Next Thread >
  1. irakli_makh

    irakli_makh New Member

    Joined:
    Nov 14, 2011
    Posts:
    9
    Likes Received:
    0
    Hi all

    I've just got discovery 2 td5. For 6 month the engine was OK. But for the lass two month I'd had to cranck for a long time to start engine, but it always got started and worked as usual. Sometimes it illuminated check engine on instrument cluster. three weeks ago I went home and the car cut out like fuel was out, fortunetaly front of gas station. I bought 10 liters and tried to purge. After 30 minutes try, engine started. I went on my way, but after 3 km happened the same, but this time I was unable to start.
    Next day I brought the car to local dealer for diagnosis and they told me that the secont fuel injector had mechanical demage. Computer did not show any other fault. they changed the faulty injector and tried to start a car. after many attempts car got started, worked normaly for about a minute and cut out. we tried to start again but the car hardly started, worked for a seconds and cut out again. they told me that there was a few ammount of diesel in the fuel tank, and I refilled it. but without result. They changed fuel pump relay, cleared air bleed pipe filter, but without any success.

    Fuel pump is ok they checked pressure and was fine. when the engine runs everything seems ok.


    PLEASE HELP!
     
  2. cuza68

    cuza68 New Member

    Joined:
    Jan 26, 2011
    Posts:
    341
    Likes Received:
    1
    injector seals.plenty of post on here for your info
     
  3. irakli_makh

    irakli_makh New Member

    Joined:
    Nov 14, 2011
    Posts:
    9
    Likes Received:
    0
    I read a lot of them but do not help me. injector seals are new I forgot to write about it
     
  4. cuza68

    cuza68 New Member

    Joined:
    Jan 26, 2011
    Posts:
    341
    Likes Received:
    1
    possible air in fuel system, damaged fuel pipe, fpr . Does the fuel pump begin to prime every time you switch the ignition on. Have you tried purging the fuel system of air? Does it complete its cycle??
     
  5. sierrafery

    sierrafery Well-Known Member

    Joined:
    Jun 30, 2007
    Posts:
    11,681
    Likes Received:
    1,299
    Location:
    West of Transylvania
    Imo it's time for a new genuine crakshaft sensor(check first the related wiring and plug anyway). The fact that the MIL came on sustains that. Though it's quite concerning that no code was stored after the MIL illuminated and that might be an ECU fault... and if your Td5 is '99-'00 generation, unfortunately this is quite comnon.(MSB101183/4 ECM's are pretty unstable)
     
    Last edited: Nov 15, 2011
  6. Shifty1962

    Shifty1962 Well-Known Member

    Joined:
    Mar 1, 2008
    Posts:
    4,209
    Likes Received:
    86
    Location:
    The Winchester Club - Englandshire
    I'd suspect the main ECU earth point needs cleaning up. You can then check out the crank position sensor wiring for damage as it often chafes through if its not clipped above the bellhousing.
     
  7. irakli_makh

    irakli_makh New Member

    Joined:
    Nov 14, 2011
    Posts:
    9
    Likes Received:
    0
    crankshaft sensor is ok, because we replaces it from a working car. After purging the car starts and works good for minutes 1 or 2. after it cuts out we found that air was in the inlet pipe. how can get the air there on the running car??
     
  8. cuza68

    cuza68 New Member

    Joined:
    Jan 26, 2011
    Posts:
    341
    Likes Received:
    1
    leak back from injectors or faulty fuel lines poss also check fuel filter asm
     
  9. irakli_makh

    irakli_makh New Member

    Joined:
    Nov 14, 2011
    Posts:
    9
    Likes Received:
    0
    As it seems my problem is cured. I have driven a car for last 3 weeks and no 1 cut out, but what was the problem is not known. the car just decided not to cut out and it works :)

    But 2 problems still exists. 1) It takes a long time cranking (like the fuel is out) to start 7 times of ten try. and 2)as it seems waste gate modulator is faulty because it stops accelerating at about 2800 - 3000 rmp. what will happen if I just eliminate the modulator and connect directly the waste gate

    thank you in advance
     
  10. irakli_makh

    irakli_makh New Member

    Joined:
    Nov 14, 2011
    Posts:
    9
    Likes Received:
    0
    where discovery 2 ECU earth is located?
     
< Previous Thread | Next Thread >