1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

Range Rover 4.2S reduced engine performance issue

Discussion in 'Range Rover' started by Martin1_01, Jun 14, 2011.

< Previous Thread | Next Thread >
  1. Martin1_01

    Martin1_01 New Member

    Joined:
    Apr 10, 2009
    Posts:
    36
    Likes Received:
    1
    Hi All,

    After my P38 failed due to engine issue, I boldly stepped up to the mark of a Range Rover 4.2S (55 plate supercharged model) which is absolutley wonderful to drive.

    However! On a lengthy drive yesterday, mainly motorway I had three "reduced engine performance" warnings, where power dropped substantially and the fault only cleared by pulling over and stopping/restarting the car. On country roads/town driving everything was fine but am annoyed with this weird intermittent issue on a car which is seemingly perfect. I read somewhere there could be a factory wiring issue with the water/cooling pump on the supercharger - is this true?

    All advice/ideas appreciated.

    Thanks.
     
  2. Martin1_01

    Martin1_01 New Member

    Joined:
    Apr 10, 2009
    Posts:
    36
    Likes Received:
    1
    SOLVED! After much investigation by Landrover and a great new piece of kit they plugged in, the fault was recreated and it turned out to be the cooling pump to the supercharger. Apparently there was high resistance showing across the wiring which caused the problem of "reduced engine performance".

    Hope this helps anyone else with such an irritating issue, the car now drives beautifully.
     
    Grrrrrr likes this.
  3. turbotommy

    turbotommy New Member

    Joined:
    Sep 30, 2014
    Posts:
    1
    Likes Received:
    0
    I have the same problem and have been quoted £300 to supply and fit by a RR dealer, may I ask what you paid?
     
  4. Saint.V8

    Saint.V8 Dyed-in-the-wool 100% RR Junkie

    Joined:
    Apr 27, 2008
    Posts:
    15,642
    Likes Received:
    1,621
    Location:
    Surrey - Near the middle, close to some green bits
    Sorry to say this thread is over 3 years old and the poster hasnt been online for almost a year!!

    Anything fitted for £300 by a dealer is a bargain if you ask me!
     
  5. ChickenGeorge

    ChickenGeorge Member

    Joined:
    Feb 1, 2015
    Posts:
    11
    Likes Received:
    0
    I have had this fault today when stopping and putting into reverse and my reversing camera didnt not work then when reversing it started to work then i had the beep beep then engine performance reduced came on the dash no lights on dash so i left it checked the oil it was a lil low so i topped it up and then drove to the garge about 5 miles away and they diagnosed it and there was no faults stored what soever and we test drove it and then tryed again but no faults no codes and no message on dash made me look as if i made it up but i did notice my reversing camera does not come on anymore?
    if anyone can help or suggest anything to prevent this again iam open to suggestions im not to worried as its not there now but may RETURN but hoping its just a computer glitch.
     
  6. wammers

    wammers STILL BREATHING. Donater

    Joined:
    Oct 19, 2008
    Posts:
    52,591
    Likes Received:
    7,723
    Location:
    Preston Lancs.
    Unless it's stop lamp bulbs. :D:D:D
     
  7. Grrrrrr

    Grrrrrr Well-Known Member

    Joined:
    Jul 8, 2012
    Posts:
    9,725
    Likes Received:
    1,606
    Location:
    Buckinghamshire, UK. ('95 DT)
    Round here that would still be a bargain. Presumably they have so much work they can afford to, although they seem more interested in selling than maintenance now.
     
< Previous Thread | Next Thread >