1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

L322 front indicator fault when locking/unlocking

Discussion in 'Range Rover' started by Benji100651, Sep 13, 2018.

< Previous Thread | Next Thread >
  1. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    Hi everyone I’m looking for some advice....I have a 2004 L322 Range Rover vogue. As of yesterday when I lock or unlock the car the front indicators don’t flash but rear and side ones do. Also when I get in the car and press the hazard warning button with no key in the ignition the front ones don’t flash. When I put the key in and turn on the ignition they then start to flash. When I take the key out they flas for 10 seconds and go off again. Has anyone had this before or any auto electricians out there that could possiblyhelp me.

    Thanks in advance
    Carl
     
  2. The Mad Hat Man

    The Mad Hat Man Well-Known Member LZIR Despatch Agent

    Joined:
    Sep 11, 2005
    Posts:
    80,579
    Likes Received:
    6,722
    Location:
    Embasinga stocæ
  3. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    Sorry I don’t know what you mean. I’m new to this. I just put my question in the wrong forum so put it in the Range Rover forum now
     
  4. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    May be the light control module having a gimp, have you got anything you can plug it into ?
     
  5. Datatek

    Datatek Well-Known Member

    Joined:
    Feb 5, 2009
    Posts:
    30,007
    Likes Received:
    594
    Location:
    Near Poitiers SW France
    Another ignition switch fault?
     
  6. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    But they are working when you turn the ignition on...once there is power they flash and when you turn the ignition off they flash for 10 seconds then go off again
     
  7. gold rover

    gold rover Well-Known Member

    Joined:
    Nov 22, 2010
    Posts:
    4,005
    Likes Received:
    1,737
    Location:
    Scotland,
    Just because they 'work when you turn the ignition on', doesn't mean the LCM isn't having a gimp, as HC so elegantly put it. I know I'm repeating his words but do you have something to plug into it?
     
  8. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    To be totally honest o don’t know what you mean? Plug what in? Sorry
     
  9. Saint.V8

    Saint.V8 Dyed-in-the-wool 100% RR Junkie

    Joined:
    Apr 27, 2008
    Posts:
    15,287
    Likes Received:
    1,418
    Location:
    Surrey - Near the middle, close to some green bits
    Diagnostics.....
     
    gold rover likes this.
  10. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    Ahh got you....no I’ve not but can take it somewhere cheers
     
  11. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    Sometimes a battery disconnect and hard reset can solve a few problems but occasionally although rarely it can make it worse, mine used to become immobilised with only a high end diagnostic getting it going again.
    If you do choose the reset then make sure you follow the correct procedure which a quick search on here will explain.
    Aftermarket LED bulbs can cause some strange problems as well, do you have any fitted anywhere ?
     
    Last edited: Sep 14, 2018
  12. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    Could be that, there are a lot of wires feeding off the ignition switch, I’ll have a look at where the LCM gets it feed from
     
  13. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    Well I’ve had the car about 4 months now and yes it has after market LED bulbs in places but never had any problems then all of a sudden one morning I’ve woke up unlocked the car and no flashing on the front
     
  14. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    My number plate LEDs were ok for a while and then began to melt and short out and caused some strange behaviour although yours sounds quite specific.
    Your indicators also work ok when the ignition is on.
    The light control module can get wet, it is in the drivers footwell, and must also have a switched live and permanent live
     
  15. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    Yeah indicators and hazards working perfectly fine when ignition is on it’s just when I lock or open the car the front don’t flash and hazards don’t work on front until I turn the key. It’s got my head done in
     
  16. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    According to rave manual there are two permanent lives goong to the light check module but they are fusible links behind the glove box fuse box so you would need to find where they feed into the LCM or find another accessible fuse or component they feed to check them easily , you can download the L322 electrical library as part of Rave normally and it looks there are another two fuses, I’ll post up a pic
     
  17. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    If the bulbs in question are LED and you had some standard ones i might be inclined to try them. Fuse 4 and fuse 9 supply the switched feed.
    Looking through the attached i can't actually see the indicators..
    lcm 1.jpg

    lcm2.png
     
    Last edited: Sep 14, 2018
  18. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    Not sure how much this is helping, if i was doing it i would plug it into diagnostics and look for codes but i have my own diagnostics, then check the fuses, disconnect the battery following the correct procedure and check the LCM for damp and making sure the wires are connected ok, check the bulbs using alternative standard bulbs.
    There aren't any individual fuses for the indicators or any other lights, that is all controlled via the LCM.

    lcm3.jpg
    lcm4.jpg
    lcm5.jpg
    lcm6.jpg
     
  19. Benji100651

    Benji100651 Member

    Joined:
    Sep 13, 2018
    Posts:
    19
    Likes Received:
    2
    Location:
    Manchester
    Thanks for all this information now time to sift through it and get looking. Your are a fountain of knowledge
     
  20. holidaychicken

    holidaychicken Well-Known Member

    Joined:
    Jun 30, 2013
    Posts:
    3,560
    Likes Received:
    853
    Location:
    Kent
    Thanks, the fountain of knowledge is the rave manual , it is exceptional in the amount of information provided.
    https://www.landyzone.co.uk/land-ro...lus-other-useful-info-on-range-rovers.322195/

    There are several separate manuals and not all are always included.
    There is a system description and operation, workshop / repair manual, electrical library and also electrical wiring diagrams, let me know if you cant find anything as i may be able to email it.
    Good luck
     
< Previous Thread | Next Thread >