1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome To LandyZone!

    LandyZone is the biggest Land Rover forum on the net. We have plenty of very knowledgable members so if you have any questions about your Land Rover or just want to connect with other Landy owners, you're in the right place.

    Registering is free and easy just click here, we hope to see you on the forums soon!

2003 Freelander--F 4 and HDC--please help

Discussion in 'Land Rover Freelander' started by Freelander322, Sep 18, 2011.

  1. Freelander322

    Freelander322 New Member

    Joined:
    Sep 18, 2011
    Posts:
    4
    Likes Received:
    0
    Hello,

    I have an '03 Freelander that is displaying the F 4 and HDC lights. The car runs fine, but has low power in 1st (Feels like 4th gear/limp mode). I've done some searching and found that it could be some solenoid/electrical problem but I haven't found any solutions or guides to help me fix this :confused:.
    I just need confirmation that this is actually the problem and some help as to how to fix it. Please help...my other car finally gave up on me so I need this car.

    Thanks
     
  2. Freelander322

    Freelander322 New Member

    Joined:
    Sep 18, 2011
    Posts:
    4
    Likes Received:
    0
    No one can help?
     
  3. The Mad Hat Man

    The Mad Hat Man Well-Known Member LZIR Despatch Agent

    Joined:
    Sep 11, 2005
    Posts:
    73,180
    Likes Received:
    1,556
    Location:
    Embasinga stocæ
    Have you tried a search?
    Look for "amigos". I would suggest that the lack of response is more likely due to the fact that the Q is asked on a weekly basis; and peeps can't be arsed to answer yet again :rolleyes:, rather than they don't know.
     
  4. Freelander322

    Freelander322 New Member

    Joined:
    Sep 18, 2011
    Posts:
    4
    Likes Received:
    0
    My apologies. The car isn't actually mine; it's my father's. I know little about landys in general so i was just describing what he told me. Come to think of it, I've never seen the car...

    sorry about creating the thread though.

    Thanks
     
  5. Hippo

    Hippo Lord Hippo

    Joined:
    Nov 22, 2007
    Posts:
    13,468
    Likes Received:
    267
    HDC can be the brake pedal switch. F4 flashing can be the auto electrical barrel connectors coming apart, or wires snagged or broken. Located above the auto gearbox. There's 2 of them. Does it struggle to pull away? If so it's in 4th gear due to the fault.

    [​IMG]
     
  6. Freelander322

    Freelander322 New Member

    Joined:
    Sep 18, 2011
    Posts:
    4
    Likes Received:
    0
    You're correct, it struggles to pull away. Do you know a part number for a replacement part or is there a way to fix it (like zipties in picture above?)
    :D
    Sorry if my questions seem vague or idiotic; I have never seen the actual car.
     
  7. Hippo

    Hippo Lord Hippo

    Joined:
    Nov 22, 2007
    Posts:
    13,468
    Likes Received:
    267
    If it's the barrel connectors that have come apart, twist them to put them back together. There are 2 of em. Then put hose clips round them (secure but not over tight) un use strong tie wraps. Be careful not to tie wrap the cable un pinch it as that’ll cause the cable stress un damage. Replacement parts? Auto gearbox harness one side, which I think comes wiv the auto. T’other side is part of a wiring loom. Mine are as above in the pic.

    The struggle to pull away is the default into 4th gear. Hence the F4 flashing. Essentially you've either lost the electrical connection to some of the sensors, or/and the solenoids. The sensors tell the phooter what’s happening, un the solenoids convert electrical energy into mechanical energy, to change gear – by hydraulics.

    Look at the connectors first. It could be a wire is snagged un shorted to metal work earth also. A transmission fluid change has known to work wonders on the Jatco auto (what yer has) but try the connectors first. This is the most popular fix for this problem.

    Have swapped me pic above for a betterer version from me betterer camera. Ere it is again.
    Edit: well it will show when the feker updates on photobucket. :mad:

    [​IMG]