Land Rover ForumsLandrover Forum

Forum LZ Shop Gallery For Sale LZ - Live
Go Back   Land Rover Zone > Land Rover Talk > Land Rover Freelander
Register Search Today's Posts Mark Forums Read

Land Rover Freelander Freelander fans, let's hear you. Forum Sponsored By: Famous Four - Land Rover Freelander Parts Supplier

Welcome to Land Rover Zone!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, photos and use our for sale section. Registration is fast, simple and absolutely free so please, join our community today!



Reply
 
Thread Tools
  #1  
Old 25th-June-2012, 22:02
Junior Member
 
Join Date: Jun 2012
Location: N.ireland
Posts: 23
Default Engine management lights /sensors

Hi , looking bit of input on my 2002 TD4 , couple of weeks ago the EML started flicking on and off (amber) only for second or so then nothing for 10-15 min then flicks on for few seconds again, got this reset at my usual local garage ( pre fuel rail pressure sensor) incase was and previous fault not reset correctly (only have landy few months), couple of days later it started again same as before no lose of power at any stage .

Then on Friday while doing shoppin with the her indoors landy wouldnt start tried several times resetting key each time then left it for 5 min and she started again, back up to garage this time faults where camshaft position sensor and pre fuel rail pressure sensor , light is starting to flick on and of more fequently and is starting to stay on for 5 secs or so 2-3 time a minute. Has failed to start on 1 more occasion Sat , have ordered cam sensor as this is causing the starting issue ( 81.50 del inc vat is this good? ).

Not to sure why light is flicking on and of do they not normally just come on? like i say power and performace have not changed, is there a common place that cable may be damaged took the plug out of the sensor and cleaned contacts to no avail.

Last edited by kendo51; 25th-June-2012 at 22:06.
Reply With Quote
LZ
  #2  
Old 26th-June-2012, 20:07
mjrimmer's Avatar
Senior Member
 
Join Date: Dec 2010
Location: Stockport
Posts: 791
Default Re: Engine management lights /sensors

Cam sensor fault normally rears its head when the engine is warm.
Fuel rail pressure sensor can suffer from dirty contacts, try removing the plug and give the contacts a good clean.
Failing that the fuel rail pressure sensor harness was known to become faulty and the cure was to Change the harness for a Landrover replacement.........if you do a search you'll find this one has been covered before and has a guide on how to do it.
Reply With Quote
  #3  
Old 26th-June-2012, 21:01
Junior Member
 
Join Date: Jun 2012
Location: N.ireland
Posts: 23
Default Re: Engine management lights /sensors

Hi , i have ordered cam sensor today and have also ordered the loom, seen the other posting and although the discription was good was looking some pictures of 1 complete so i can see exactly how to do it.
Reply With Quote
  #4  
Old 27th-June-2012, 16:57
Junior Member
 
Join Date: Jun 2012
Location: N.ireland
Posts: 23
Default Re: Engine management lights /sensors

Faults all sorted fitted new cam sensor and seen connectors over near the filter and thought they look strange moved the wire and cable fell out , recrimped it and eml no off problem with ctarting and fuel pressure fault cured , Now just to send the loom i had ordered back
Reply With Quote
LZ
Reply

Thread Tools



All times are GMT +1. The time now is 11:47.

Content Relevant URLs by vBSEO 3.2.0
Page generated in 0.06797 seconds with 8 queries