Land Rover ForumsLandrover Forum

Forum LZ Shop Gallery For Sale LZ - Live
Go Back   Land Rover Zone > Land Rover Talk > Land Rover Discovery
Register Search Today's Posts Mark Forums Read

Land Rover Discovery Got yourself a Disco? Get yourself in here! Forum Sponsored By: Mailorder4x4.com accessories & parts for your Disco Every Part Covered!

Welcome to Land Rover Zone!

You are currently viewing our site as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, photos and use our for sale section. Registration is fast, simple and absolutely free so please, join our community today!



Reply
 
Thread Tools
  #1  
Old 21st-August-2008, 19:13
Junior Member
 
Join Date: Jan 2008
Posts: 17
Default Discovery 2 Auto M & S Warning Lights

Hi, I'm looking for some help! I have a 2000 Disco 2 TD5 Auto ES. I have a serious intermittent fault. The car starts and drives. It starts to miss intermittently. Yesterday I did 120 miles then I lose my throttle and the M & S gearbox warning lights come on. I pull over, stop the car and leave it for a couple of minutes. I wait for the immobiliser to set itself, press the LR button on the key then start it with my throttle fully depressed and it starts and works fine - off I go, no lights no problems 'til it does it again. Happened many times now with no pattern. HELP!!!!!

PS it's had a new main ECU as the old one had oil in it. It lasted 300 miles before it did the above again.
Reply With Quote
LZ
  #2  
Old 21st-August-2008, 21:46
Member
 
Join Date: Jul 2008
Posts: 36
Default Re: Discovery 2 Auto M & S Warning Lights

If you had oil in the ECU has the injector loom been changed?
I was getting these warning lights a couple of times (on start up though in our case) but it has not happened since clearing the oil and changing the loom.
Reply With Quote
  #3  
Old 22nd-August-2008, 07:02
paul.ascroft@bmw.co.za's Avatar
Member
 
Join Date: Dec 2007
Location: Pretoria, South Africa
Posts: 72
Default Re: Discovery 2 Auto M & S Warning Lights

I had a similar problem when my TD5 was struggling to start. My local indy told me that the gearbox and the ECU were not communicating properly. The car defaults to limp home mode then.He thought it could be the selector switch on the G/Box worn so it didn't really know which gear it was in. Anyway. cured the starting problem and the fault has not appeared since. Sometimes though when I shift to Park, the "P" does not light up on the dash. If I push the lever hard forward it lights up.
Reply With Quote
  #4  
Old 22nd-August-2008, 13:36
Junior Member
 
Join Date: Jan 2008
Posts: 17
Unhappy Re: Discovery 2 Auto M & S Warning Lights

Thanks guys. The injector loom and ECU were changed a month ago. The gearbox 'XYZ' switch has also been replaced. I spoke again to the engineer who thinks that the oil has ingressed further down the main loom, not just to the ECU and injector loom. He said that my choice was to spend an indeterminable amount on Auto electrians or replace the main loom which he said was 600 plus fitting - several days??? (or both) Either way it would potentially cost a prohibitive amount.
I understand there is an 'engine loom' which is a bit cheaper. Has anyone changed one of these?
Reply With Quote
  #5  
Old 22nd-August-2008, 14:37
battenberg's Avatar
Senior Member
 
Join Date: Sep 2006
Location: Birmingham UK
Posts: 2,055
Default Re: Discovery 2 Auto M & S Warning Lights

i constantly get oil in my engine loom at the ecu, but every couple of months clean it out with WD40 and air.
Reply With Quote
  #6  
Old 22nd-August-2008, 17:41
Member
 
Join Date: Jul 2008
Posts: 36
Default Re: Discovery 2 Auto M & S Warning Lights

I would check the ECU end again. I have cleared oil from it twice since the injector loom was changed (dry at engine end) as I suppose there is still oil 'migrating' down the wiring.
After the 2 cleans it is just about gone now.
Reply With Quote
  #7  
Old 28th-August-2008, 15:37
Member
 
Join Date: Nov 2006
Location: Brentwood, Essex
Posts: 30
Default Re: Discovery 2 Auto M & S Warning Lights

Hello,

this sounds similar to the problem we had on our 2001 Discovery auto. It would run ok for a while, then start to almost misfire and then as you explain "M" and "S" lights illuminate on dashboard. Engine was still idleing, but, throttle seemed inoperative. After switch off and restart, everything would be fine again until it did it again.

After much diagnosis and even connecting to testbook, it was a suspected gearbox/ loom problem. It actually turned out to be the throttle assembly. Because it is drive by wire there is a solenoid on there which can fail. One throttle assembly later and problem was cured.

Strange thing is that no fault code initially showed on testbook and then upon third hook up several weeks later, it did.
Reply With Quote
  #8  
Old 28th-August-2008, 19:41
eightinavee's Avatar
Senior Member
 
Join Date: Jan 2006
Location: Near Bath,SW UK.
Posts: 3,615
Default Re: Discovery 2 Auto M & S Warning Lights

Much more likely is that the front part of the engine loom has rubbed through,(usually near the A/C comp,EGR pipe etc.) this shorts the 5v supply to the AFM and ambient temp sensor.This 5v supply also feeds the throttle pedal.When the supply is lost the engine ecu cannot get a driver demand signal so drops the rpm back to idle and faults.At the same time it can no longer send a proper CAN signal to the gearbox ecu,so this faults as well and puts the EAT ecu into limp home mode and flashes the S and M lights.
So you switch off,then restart - the jiggling of the engine whilst cranking hopefully moves the loom enough to remove the short and off you go.
Reply With Quote
  #9  
Old 2nd-November-2008, 09:45
Member
 
Join Date: Sep 2006
Posts: 69
Default Re: Discovery 2 Auto M & S Warning Lights

Bugger, i had the same problem last night on day two of ownership at 2am on the M1, book at home next to bed for night time reading so had no idea what had happened, the lights came on though when the car jigglrd and tramlined so this last response sounds the most likely for me. Gonna chack it out. Cheers, search is my friend.
Reply With Quote
  #10  
Old 5th-November-2008, 13:44
Member
 
Join Date: Sep 2006
Posts: 69
Default Re: Discovery 2 Auto M & S Warning Lights

Showed solenoid valve 2 fault, only happened the once hasnt happened again, dealer said hed neer heard of it but did check all of the suggestions mentioned here and seemed very knowledgable, didnt charge me either. Mitsi wanted 100 + VAT for a diagnostics check, robbing bar stewards!

All is well in the land of the Landy. Althought the boot door is a bit stiff, WD40'd it which helped. Lovin driviong it, seriously considering som emore power though, its the only thing it lacks!

Car juddered under a bit of tramlineing on the M1 so think it must have shaken something the wrong way.

Last edited by alexst; 5th-November-2008 at 14:14.
Reply With Quote
LZ
Reply

Thread Tools



All times are GMT +1. The time now is 13:13.

Content Relevant URLs by vBSEO 3.2.0
Page generated in 0.10718 seconds with 8 queries